Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

Configuration : Drupal 7.26 / Omega 3 / Delta module
An accessibility check made with achecker.ca on a website gives me one result :

Success Criteria 2.4.6 Headings and Labels (AA)
Check 38: Header nesting - header following h2 is incorrect. Repair: Modify the header levels so only an h3 or any header less than h3 follows h2. Error Line 112, Column 7:

<h2 class="site-name"><a href="/fr" title="website homepage"><span>for ...

As I understand, it comes from the file : "sites/all/modules/delta/delta_blocks/includes/delta_blocks.theme.inc"
The delta for the site slogan is defined as a h6, which doesn't match with WCAG 2.0 (AA) requirement :

The header following an h2 is h1, h2 or h3

(http://achecker.ca/checker/suggestion.php?id=38).

So I might need to use a hook to change it, but I am such a newbie with hooks. I found this : https://api.drupal.org/api/drupal/modules!block!block.api.php/function/hook_block_info/7 but it seems to hook the core module. Not very sure I want to do it.

Any help?

share|improve this question
1  
Sure it doesn't, but what's your question? It appears you want us to fix Omega theme for you. If that's the case, you're in bad place - it should be posted in Omega's issue queue instead. –  Mołot Feb 4 at 13:17
1  
well, no, I don't want anybody to do anything at my place. The question was more about : does anybody had this issue and if yes or no, anybody could help me understanding if this is a Delta module issue or if there was a hook that I could use to fix it that I don't know about. So I'll look into the possibility to report it as an issue as you suggest and maybe patch it myself if I can. By the way I think it is very unappropriate to talk to me the way you do considering that we are on a place to ask for help, so maybe you are in the wrong place. –  Tritof Feb 4 at 14:09
add comment

1 Answer 1

up vote 3 down vote accepted

Hooks won't help you with this - the markup for the slogan is in the region--branding.tpl.php template file:

<h6 class="site-slogan<?php print $class; ?>"><?php print $site_slogan; ?></h6>

To fix, you can just create your own region--branding.tpl.php file in your sub-theme, and alter the markup to your needs.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.