Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I just enabled the Privatemsg Module in my Drupal 6. I would like to enable this module to all users, who join in the website. But the registered users cannot see the "Write new message and Messages" link.

Why the Privatemsg is not active in users section ?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

You should change permissions for the Privatemsg module for authenticated users or whatever role you want in the permissions page(admin/user/permissions)

See http://drupal.org/getting-started/6/admin/user/permissions

share|improve this answer
    
Thanks hNiK, it works fine. –  Ashok KS Oct 13 '11 at 5:18

In case you're talking about the local task in the user profile, that is meant for administrative purpose only (read all private messages permission).

The Privatemsg pages reside below /messages, a link to that page should have been added to the Navigation menu.

Privatemsg 6.x-2.x does allow to move it to the user profile by setting the url prefix in the settings to "user/%user/something".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.