Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

Problem: User's "Add Content" menu item is available, but "Find Content" is not.

User has role Content Editor. Content Editor has permission for "Access the content overview page". User can access http://example.com/admin/content.

Clearing all caches does not fix the problem.

share|improve this question
    
I'm not able to reproduce this problem on a clean Drupal 7 installation — giving Authenticated User the "Access the content overview page" and "Use the administration toolbar" permissions causes the "Find content" link to appear in the Shortcut bar when that user is logged in. –  smokris Jan 31 '12 at 20:26
    
OK, thanks for checking. I didn't have the "Use the administration toolbar" permission -- the Administration Menu Toolbar Style module was enabled but the Toolbar module was not. When I enabled Toolbar (tried with and without Admin Menu Toolbar Style) and gave Content Editor the permission, it still didn't fix the problem. (The triangle menu with Add Content / Find Content wasn't even there.) Maybe I'll have to give up and reinstall. –  jlstrecker Jan 31 '12 at 21:54
    
Sounds like a menu problem and not a permission issue. Try manually re-adding the menu item before completely re-installing. –  Citricguy Feb 1 '12 at 4:45
add comment

2 Answers 2

up vote 4 down vote accepted

Problem: User's "Add Content" menu item is available, but "Find Content" is not.

Solution: Manually re-add the missing menu link.

How to add an item to the admin short menu...

Click Edit Shortcuts

Click Edit Shortcuts

Add a new shortcut

Add a new shortcut

Enter a Title, A URL and then Save

Enter title, url and save

You will now have the 'Find Content' shortcut in your admin shortcut bar as needed.

Side note:

If viewing admin/content you can also add the shortcut by simply clicking the + as noted in the graphic below:

Example

share|improve this answer
    
The question says Content Editor has permission for "Access the content overview page". –  smokris Feb 1 '12 at 4:16
    
Completely rewrote the answer to address the question. There is no longer a reference to "Access the content overview page" –  Citricguy Feb 1 '12 at 4:35
    
Expanded on how-to instructions as well. OP indicated that they can already access the page in question, so permissions isn't the issue. This sounds like a menu issue. The above should re-add the 'find content' link as needed. –  Citricguy Feb 1 '12 at 4:41
    
Cool. Thanks, @Citricguy. –  smokris Feb 1 '12 at 5:37
    
Thanks -- you pointed me in the right direction. I just had to enable Toolbar module (NOT Administration Menu Toolbar Style) and Shortcut module, and then Find Content appeared. –  jlstrecker Feb 1 '12 at 15:56
add comment

Citricguy's answer is good, but it only adds a shortcut, when the op was actually asking about a menu item, which is what I wanted as well.

I've since realised that the default behaviour in Drupal 7 is for the admin (UID1) to get the "Management" menu as their black menu at the top, whereas all other users get the "Navigation" menu. You can however change this by granting users the permission "Use the administration pages and help". This is a valid solution because they will only see links to pages that they have permission to view/edit.

I personally think this should be the default behaviour (start off with everything, and then hide menu items that they don't have permissions for), but then I guess the current system allows you to manually hide certain menu items for non-admin users while keeping it for the admins. Certainly this area needs some thought as to the configuration options.

There's also the Administration Menu Source module, which allows you to "use a different menu as the Administration Menu. Configurable per role".

share|improve this answer
    
This fixed the problem for me. I had updated Drupal and modules to the latest versions (after not having upgraded for 2+ years) and the "Find Content" item was missing for one of our roles. Adding the "Use the administration pages and help" permission to that role fixed the problem. Thank you! –  donut May 27 at 17:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.