Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I am trying to use this jQuery Bubble script plugin with my Drupal 7 site. The plugin requires Jquery 1.6.2 (Drupal 7 only comes with 1.4.4).

There are some solutions on the net but none seem to work:

  • jQuery Update: It only updates jQuery to 1.5. There is a sandbox version that will update it to jQuery 1.8, but its too complicated to use.

  • jQuery Multi: I have installed 1.6.2 using this module; however, my site still loads the default jQuery 1.4.4. Version 1.6.2 does not seem to load.

  • Using Newer Versions of jQuery: This is a technique for loading multiple jQuery in Drupal 6. Although it works in Drupal 7, my Bubble plugin wont run.

My site is only a simple 1 page webform, so I would be happy if I could supress the default 1.4.4 and then just link to 1.6.

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

Looks like there is a patch for the jQuery Update module to update it to jQuery 1.7.

share|improve this answer
1  
Have you tried this patch? Does it break any admin functions? That is a common problem with jQuery updates for Drupal. –  MPD Feb 10 '12 at 20:07
    
@MPD I haven't had the opportunity to check out this patch yet. –  TheSavage Feb 10 '12 at 20:20
1  
The patch is quite hard to apply, as it has to patch multiple files. Is there are ready made version available? Thanks! –  big_smile Feb 12 '12 at 20:17
5  
@big_smile Install the dev version of jQuery Update, it has the option to use v1.7, no patches needed. I've used it (albeit in test environments) without any problems so far –  Clive Mar 12 '12 at 22:31
add comment

The jQuery Multi module, which you mention in your question, uses jQuery's noConflict() mode. If you installed jQuery Multi and jQuery didn't load, it's likely that you didn't specify any files to load with the new version of jQuery. If you don't specify and files or libraries using the UI or provided hooks, jQuery won't be loaded by default. There is a setting in the configuration form to load jQuery even if no files are targeted to use it.

To use jQuery 1.6.2 with your script, you have to write code to target that file, or put it as a library in the sites/all/libraries folder and select it in the jQuery Multi UI.

If this still doesn't work, try posting an issue in the issue queue!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.