Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I am currently using Drupal 7, and I am trying to get my images to be displayed in a view on the main page. So far I have created:

  • Created a content type containing a title, body and image field
  • Created two nodes that both contain an uploaded image
  • A view and a block that has
    • fields: title, nid, and image
    • filtered by: published and type (set to the content type I created)

When I look at my content type I can see the name, body and the image that I uploaded. When I go to the main page, I can see my view with the content, but it only shows the name and the body; it doesn't show the image.

Is there anything I can download and/or do to make this work? I just want the images to appear within the block (in my view).

share|improve this question
    
i have the same problem... and it worked before, but it appeared in one moment =( –  user1346 May 19 '11 at 10:11
    
@seremenko I did solve this problem though I can't remember how. Are you still having this problem because if so I can look up what I did later. –  Kyra May 19 '11 at 15:44
add comment

4 Answers

up vote 2 down vote accepted

check admin/user/permissions page. if you use imagecache check view imagecache permission and set it. and set view image field permission.

share|improve this answer
    
I don't think I use imagecache. I did however set the people/group permissions to have access to view/edit/delete the images/etc and I still doesn't show up in the view/block. –  Kyra Apr 18 '11 at 14:23
    
check admin/user/permissions page and content_permissions part. set image field view. also check css and image field id in style.css. maybe image display is none or visibility is hidden. you can use firebug and search image field. –  a.v Apr 19 '11 at 3:38
add comment

@Kyra, I do have the exact same issue with image field not showing in view, and this, since I've updated the view module, I'd say. The thing is I use Drupal Commerce (with Drupal Core 7), but I don't think the issue is directly related : I set a view on the front page, displaying products.

In the "Format" area :

  • Format: Grid | Settings
  • Show: Fields | Settings

In the "Fields" area :

  • Content: Title
  • Content: Body
  • Field: Illustration

In the "Filter" criteria :

  • Content: Published (Yes)
  • Content: Sticky (Yes).

The view only displays the title and the body. Of course, when I look at the content types, outside the view, their image is shown. This occurs for all content types and products created before the update of the view module. Because, if go through the process of creating a new product type, product, product display and finally a content (dedicated to the product I've just created), there, I get the the image of it in the view. So it feels like some constraints in some tables have been messed up. Did you manage to solve this issue Kyra ?

share|improve this answer
    
I managed to solve this issue. Thank you. –  Kyra Jan 23 '12 at 15:53
add comment

For future reference, check the content type "manage display" tab. There is a subtab for "content" and "teaser", so you have to make sure the picture field is being displayed there (and not hidden). You can also change the format, etc.

share|improve this answer
add comment

When you create a node, below the body field there is the "Text format" combobox; choose "Full HTML," and everything will be ok.

share|improve this answer
add comment

protected by kiamlaluno Jan 2 '13 at 13:07

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.