Drupal Answers is a question and answer site for Drupal developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Running Drupal 7, Views 3 and panels 3

Been searching for an answer for this for a few hours now and I can't seem to find one. I am creating a custom user profile page in panels. I created a view to display certain fields from profile2 if that user is of that role. When I test the view at the bottom of the views page by passing it an id it works fine. here are the settings:

Contextual filters:

(author) User: Profile

Now in panels when I add this view I have the heading Content: Nid with a drop down list in the options. I select the information I want to display and save. Then when I go to the profile page, nothing shows up. I don't think it is passing the nodeid to the view, but I am not sure what I haven't done.

share|improve this question
up vote 7 down vote accepted

If you create the view as a content pane (panel pane), you are able to select options used in panels on how to receive the context params, (Like from a Panel context of type Node). When adding the content pane in Panels you also get to select which variables should be sent to the view. This is probably what you are missing.

SS 1 enter image description here

share|improve this answer
Actually I forgot to mention that step. I do already have this and still nothing shows. When I go into panels and select add content and then click on the view I created it asks what version of the view I want (block, page, etc) but the only choice I have is "master" ... shouldn't there be a choice called "content pane"? – Jeremy Mar 26 '12 at 19:25
@Jeremy You're doing it wrong. The content pane will show up in "View panes". If you select it under views, you don't get the integration that content panes provide. – googletorp Mar 26 '12 at 19:56
I knew it boiled down to me being a retard. Thanks, I spent so much time on that and if I had just taken a second to go over the documentation again.... anyways thanks! – Jeremy Mar 26 '12 at 22:11

In Module list: look out for Chaos Tools → then ativate the submodule: Views Content Panes (Allows Views content to be used in Panels).

Practically you'll find this new feature while on the Views UI when add a new Display (you'll notice Content Pane display)

Checkout this tutorial: http://dev.nodeone.se/node/555

share|improve this answer

Here's what I did to get it to work:

  • goto: admin/structure/panels/settings/panel-page
  • click on Allowed View panes content
  • Check the box of the view you want to add in panels

    Note: It might be necessary to create a "Content pane" view using the views module of the view you want to add.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.