Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I've been using Ckeditor for a while to add text to created nodes.

But when editing the same nodes as an authenticated user, Ckeditor doesn't show the text in the body.

It still works for the administration role.

share|improve this question
    
Do you mean that no text appears at all, or that the authenticated user cannot see the CKEditor interface? –  Chapabu Mar 27 '12 at 15:28
    
The Authenticated user can see the Ckeditor interface, but not the text. –  uzair Mar 27 '12 at 15:34
add comment

2 Answers

up vote 1 down vote accepted

Try updating the Ckeditor, its usually due to the security update.

Do a update or uninstalling and reinstalling the Ckeditor and

do download the newest Ckeditor and

place in the sites\all\modules\ckeditor\ckeditor.

Just enable the module and clear the cache and you're ready to go.

share|improve this answer
add comment

You have to give the Authenticated user role the rights to use the input format CKEditor used to save the page. Look on the access rights page, URL depending on Drupal version.

share|improve this answer
    
All rights given to the Authenticated user to access, edit Ckeditor for the Drupal 7 version. –  uzair Mar 27 '12 at 15:37
1  
And the input format too, like in Use Full HTML input format ? –  Countzero Mar 27 '12 at 15:49
    
Yes! its a Full HTML input format! –  uzair Mar 27 '12 at 19:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.