Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I am receiving this error message after enabling a module. I am running Ubuntu on a Vbox. My php-apache.ini file has this line:

; Maximum input variable nesting level ; http://php.net/max-input-nesting-level max_input_nesting_level = 200

I thought this was the correct setting for nesting functions, however, since it is set to 200 and I am erroring at 100, it may not be. Is there another setting or file I am missing? Is there any other Drupal related file that holds that setting? How can I find it?

Additional Info.

I found several questions on stackoverflow that suggested this might be caused either by Zend or xdebug. I believe I turned off xdebug by commenting out the xdebiug.ini file which, for Ubuntu linix is in the etc/php5/conf.d/directory. It appears to have eliminated the error, although the module I was enabling does not appear to have installed on the admin menus completely.

share|improve this question

closed as off topic by kiamlaluno Nov 22 '12 at 22:24

Questions on Drupal Answers are expected to relate to Drupal within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
It probably doesn't matter if it's 100 or 200, that sounds like a loop to me. –  Berdir Apr 10 '12 at 19:25
    
If I refresh the admin/module page after receiving the error, it will then display correctly without the error message. –  Ashlar Apr 10 '12 at 19:48
    
I just re-ran the module enable using drush which gives be the same error and it lists the function calls. There are 99 shown and there does not appear to be a loop. –  Ashlar Apr 10 '12 at 20:19
    
drupal.org/node/224399#comment-1496310 xdebug.max_nesting_level=200 in php.ini could you enable xdebug and check this ? btw which module are you talking about –  GoodSp33d Apr 11 '12 at 4:07
    
@kantu That appears to have done it :) I found a lot on google discussing the error, but did not see this ini line. Please put this in an answer and I'll accept it! –  Ashlar Apr 11 '12 at 13:25

3 Answers 3

up vote 2 down vote accepted

According to this xdebug.max_nesting_level=200 solved for some of them

Could you enable xdebug and check this ? In which module are you getting this error ?

share|improve this answer

Silly question maybe, but are you sure that you are editing the active php.ini file? You can check this by creating a file with the phpinfo function in it, putting it on your web space and visiting it through your browser:

<?php
  phpinfo();
?>
share|improve this answer

Add the following to the beginning of your index.php if you are using xdebug:

ini_set('xdebug.max_nesting_level', 200);

share|improve this answer
1  
It has been already suggested from the accepted answer. –  kiamlaluno Nov 22 '12 at 20:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.