Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

Consider my domain is domain.com. Currently I am transfering my domain to another server(GoDaddy Plesk). I am testing the site by chaining my DNS. When a payment is made in ubercart email is not going to the @domain.com mail address alone for other address emails are going (I am not sure wether it will change after the site is live). So I planned to change to SMTP authentication.

I have configured correctly in site.com/admin/settings/smtp. I am able to get the test email from my site admin. However, when I try to register a user I am getting a error message at the top of home page. Following is the error message.

warning: fputs() expects parameter 1 to be resource, integer given in *****/httpdocs/sites/all/modules/smtp/phpmailer/class.smtp.php on line 212.

Any help is greatly appreciated...

Thanks in advance..

Mail server I am using is smtpout.secureserver.net and the port is 80

EDIT I am using Drupal 6.19 and php 5.3

Now I tried to send email the email went.

Following is the debug log:

SMTP -> FROM SERVER:250 zSiJ1i0093a4YER01SiJLw mail accepted for delivery 
SMTP -> get_lines(): $data was "" 
SMTP -> get_lines(): $str is "221 m1plsmtpa01-08.prod.mesa1.secureserver.net closing connection " 
SMTP -> get_lines(): $data is "221 m1plsmtpa01-08.prod.mesa1.secureserver.net closing connection " 
SMTP -> FROM SERVER:221 m1plsmtpa01-08.prod.mesa1.secureserver.net closing connection    
share|improve this question

closed as too localized by kiamlaluno Apr 23 '12 at 16:45

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What Drupal Version? What PHP Version on the servers? Could you please go to admin/config/system/smtp and enable the option "Enable debugging" and post back here what you see? I think PHPMailer is not able to open a socket to the SMTP server. –  whitefleaCH Apr 18 '12 at 13:35
    
What version of phpmailer are you using? Note that the SMTP module does not support the latest version of phpmailer (versions higher than 2.2.1 are NOT SUPPORTED). –  Nikhil M Apr 18 '12 at 13:37
    
Here is a tut iniu.net/content/install-tricky-drupal-smtp-module-email –  Nikhil M Apr 18 '12 at 13:38
    
Thanks for answering me..following is the error I am getting when sending a test email..At first I was getting the test email now I am not getting that also.. following is the error SMTP -> FROM SERVER: SMTP -> NOTICE: EOF caught while checking if connectedSMTP -> ERROR: AUTH not accepted from server: SMTP Error: Could not authenticate. –  Dilip Rajkumar Apr 18 '12 at 14:02
    
Drupal version I am using is 6.19 –  Dilip Rajkumar Apr 18 '12 at 14:04

1 Answer 1

up vote 0 down vote accepted

After a long battle I found out we need to put SMTP server as. s2smtpout.secureserver.net and port as 25

Hope this helps some one..

share|improve this answer
    
So it was a configuration mistake !! ? –  Nikhil M Apr 23 '12 at 9:51
    
Yes Nikhil, I am not sure. me and godaddy exchanged many emails finally they did some thing on my server and told this was the URL I need to use for SMTP. This information I did not find in any documentation of GoDaddy.. –  Dilip Rajkumar Apr 23 '12 at 10:42
    
Thanks for all your help Nikhil.. –  Dilip Rajkumar Apr 23 '12 at 10:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.