Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

Does anyone know, how I can manage TinyMCE to insert <br> instead of <p>Paragraphs</p> when pressing enter?

The best would be if you press enter once, it inserts a normal break. Pressing enter twice it starts a new paragraph.

And yes I know, that Shift+Enter would do it, but my client would like to have the behavior changed.

Thanks for any help

share|improve this question

2 Answers 2

Give shift+enter a try.

That shortcut tends to be the default in a lot of different text editing apps for break type switching.

share|improve this answer
    
Thanks for your answer... but I know that behavior... but my client doesn't like that ;) –  Lumio Jun 22 '12 at 23:42
    
tinymce.com/wiki.php/… –  Ayesh K Nov 8 '12 at 3:08

You need to adjust the WYSIWYG settings from /admin/config/. In CKEditor the section Cleanup and output has options for Enter mode and Shift+Enter mode where you set the tag for each action. I'm not 100% about the exact setting for WYSIWYG, but it should be similar.

share|improve this answer
    
Yes, but that's only for CKEditor and the question was about TinyMCE... –  Druvision Dec 15 '13 at 3:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.