Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I'm using the latest D7 & securepages. When I took over this website from the previous dev. They had the problem that when they would update "anything" (according to them) it would break the SSL. I didn't believe them, so I cloned the site to a sub domain and updated everything. It still worked. My pages in the shopping cart turned into https so everything was good. The only problem is, that now it doesn't turn green (still https thou) and we are paying for an extended cert. So now the boss is asking why it doesn't turn green.

I checked the certificate and got the following;

Website: www.[site].com <- this is correct
Owner: This website does not supply ownership information.
Verified by: Not specified

This wouldn't happen prior to the update. What is causing this and how can I fix it?

EDIT: I was able to get a full SSL connection again. I was one of my images that I manually edited in one of my template files. So now that I have a full SSL connection again, I guess the question has changed slightly to; Why isn't it green? The only thing I notice when checking the cert is that it shows: This website does not supply ownership information.

For anyone else encountering this issue with secure pages; In your settings file, make sure that if you have redirections to www.example.com or example.com. That you have your $cookie_domain is set properly.

share|improve this question
    
This doesn't sound like a Drupal question anymore. You may have better luck at ServerFault. –  MPD Jul 4 '12 at 13:48
add comment

1 Answer 1

up vote 2 down vote accepted

I am not sure if it would cause your problem, but Secure Pages requires patches to core. The two you need are listed on the main project page. I use 961508-23-32-D7 instead of 961508-21. I am not 100% sure which version of 471970 I am using (that is just for unit tests, anyway). Both apply to 7.14, but with some fuzz.

share|improve this answer
    
Thanks for the help MPD. It ended up being that I needed to set my $cookie_domain in settings.php. I believe this was due to my .htaccess settings redirect all urls to www –  Digital Fire Jul 5 '12 at 14:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.