Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

On logging on to Drupal administration page, I get an error message:

One or more problems were detected with your drupal installation.

I've tried disabling modules.

Is there a way to hide this message?

share|improve this question

migrated from stackoverflow.com May 17 '11 at 10:44

This question came from our site for professional and enthusiast programmers.

    
The problem is not fixable? –  Pekka May 16 '11 at 9:34
    
but actually i dont find any problem with the installations.. –  Gochu May 16 '11 at 9:43
    
Well, what does the message say? It must give some more detail than that somewhere? –  Pekka May 16 '11 at 9:43
    
had error - You are using a feature that requires $cookie_domain to be set, but it is not set in your settings.php below FCK editor optionin status report, so added $cookie_domain.. now it shows the following message: You are using a feature that requires manual integration into config.php (either built-in filebrowser or quick uploads are enabled in the Advanced profile). You have added "require_once ..." statement in editor/filemanager/connectors/php/config.php, but in the wrong line. –  Gochu May 16 '11 at 10:46
    
now that i ve run cron, the only warning shown in status report is the one mentioned above, any idea what its pointing? –  Gochu May 16 '11 at 10:50

5 Answers 5

up vote 3 down vote accepted

The error you reported is caused by a module that implements hook_requirements() to check if some conditions are verified. Instead of hiding the message, you should check what caused the error message by visiting the "Status report" page, where the module that caused the error message to appear will explain the cause of the error.

Keep in mind that also Drupal core modules cause the error to appear, for example when you need to run the module updates to update the database tables used by a module.

share|improve this answer
    
yes went to status report page n fixed it.. some issue in write permissions etc... thanks –  Gochu May 17 '11 at 3:54

You could check the status report and try to resolve the error but I guess you are happy to leave it that way.

Or you could hide the message by selecting the class and choosing not to display it using CSS. Create a file called style.css in your "Theme" folder (alongside the location of page.tpl.php) and place the class within it (you can check the class by using Firebug/Inspector "right click on it, then inspect element").

I think the class will be .warning or .alert, and an example CSS code would be:

div.warning, .alert, div.error, tr.error
{
display:none;
}

This would however hide all alerts and warnings for elements with the same class. So be careful because you could miss other critical notifications. You could have a style sheet for non-admin users that would turn this off and another for admin areas that would display these messages. Its your choice.

share|improve this answer
    
oh and make sure you flush all caches and run cron. –  David May 16 '11 at 10:22
    
Thanks, i will try it if nothing else works –  Gochu May 16 '11 at 10:46
1  
It's absolutely not the right action to do, you need to fix the issue instead of just hiding it. –  Artusamak May 16 '11 at 11:58
    
I suggested he look at the status report and try to fix the issue, but the question that was asked was any way to hide these messages? There are many valid reasons why a developer might want to hide these messages from certain users, and I pointed that out. Also for someone on shared hosting it may not be possible to go into MYSQL and clear out tables that have been left by disabled modules in the database. It is always best to fix errors, but the question implied he wanted to disable the error message. –  David May 16 '11 at 14:13
    
i really wanted to get rid of the error message somehow, havent done much in drupal so did nt know the details, or wat all was possible.. thats y i put the question in that way.. –  Gochu May 17 '11 at 4:03

Instead of hiding these errors, you should configure properly corresponding modules...

Anyway, you can simply hide these errors in Site configuration > Error reporting (no need to add css rule for this).

share|improve this answer
    
yes, there was an issue in code placement in fck 's config.php file.. ok thanks to all.. got the issue fixed.. –  Gochu May 17 '11 at 3:52

It can be also a deactivated module, that was the problem on my drupal installation

after the activation, i got updates for it and updated it and then the error was gone

share|improve this answer

You can hide it temporarily as Go to admin/settings/error-reporting and change Error Reporting settings to Write Errors to Log

There's a module to install to show it only to admins https://drupal.org/project/disable_messages

I know you need to fix these errors. But meanwhile all users to your site see these red messages. They don't affect anyone except logged in users normally and may be completely minor - I got a whole lot of red errors suddenly - and no problems continuing to use the site, just said I need to do a security update.

So why by default, show to all visitors to the site? Admins will typically be logged in when they visit the site anyway.

Is different if typical users are logged in, but in my case for instance, I'm the only user and only admin (except for the site designers who designed the site for me), just using Drupal to make a site to present content about software I sell.

In a situation like that, the last thing you want is for visitors to your site who want to buy your software to be faced by a page of red errors filling the entire screen before they get to the content they have come to read. That could mean losing all your sales for one day or for several days if you happen to be on holiday.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.