Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I have this problem when with my view's header. I am allowed to enter a translation but the translated text is not rendered when the view is displayed in that language.

I have the following warning in the Views interface: content for textgroup views is not allowed for translation because of its text format.

I read other posts suggesting to go to Configuration » Regional and language » Multilingual settings and verify that the text format is selected. This posts were addressing the problem for blocks and it did not solve my problem. Any similar experience or solution?

Drupal 7 - Views 3

share|improve this question

1 Answer 1

I had the same problem, then found a solution. I'll show you the details with screenshots.

  1. First enable Internationalization Views (i18nviews).
  2. Create your custom view. For example, I'll simply list the nodes related to Article content type.
  3. Add a header:
    1. Click on "add" next to Header section Header - add
    2. Add "Global: Text area" Global: Text area
    3. Type your header text, and select your input format. Please note that I selected "Filtered HTML" here! header text
    4. Click Apply
  4. After saving the view, you'll see notice, telling that this header text can not be translated, so in my case:
    "The string views:list_articles:default:header:views:area:content for textgroup views is not allowed for translation because of its text format."
    Views - translation notice for the header; The string <code>views:list_articles:default:header:views:area:content</code> for textgroup <code>views</code> is not allowed for translation because of its text format.
  5. Go to admin/config/regional/i18n/strings (Home » Administration » Configuration » Regional and language » Multilingual settings » Strings)
  6. Check the appropriate text format you used above, when adding a header text, it must be the same - so in my case, it's "Filtered HTML" -, and then click Save configuration. admin/config/regional/i18n/strings - checking the appropriate input format
  7. Now go back to your custom view, and on the right dropdown menu, click "translate view": translate view
  8. Now you'll see this: translate view 2
  9. Click on one of the "translate" links. After that, you'll see the following screen, and a message that the appropriate string for the header text translation has been created - which means from now on, you can translate it! Created string for text group views
  10. Scroll down to the appropriate header text, and translate it: header text to be translated
  11. After translating, click on "Save translation".
  12. On the following screen, you can see that some translations have been saved.
  13. Now when switching to the other language, you'll see that the header text is translated! You are READY! Views header text is already translated
share|improve this answer
    
I know I'm very late with this, but this doesn't seem to work. When adding the translations everything is fine and looks good but if you change the original (in my case english) content, all other languages get updated with the english text and you have to go through them one by one again to change them back to their own language. –  xaddict Mar 29 '13 at 11:51
    
@Sk8erPeter Thank you very much, Its working great on Views 3.7. –  user2519032 Jan 2 at 22:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.