Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

The Feed module successfully imports a RSS feed. However the Description field does not display. I can only see it if I click on "Edit". The problem is that the feed-items do not have a text format.

How can I give the Description field a default text format?

share|improve this question
    
In Views, I can either set the text processing for Description field for the feed-item to be in plain text - and then see my html tags turned into ugly plain text. Or I can set it to be full-html and then I see nothing. How can I import feeds in full-html? –  Aaron Kreider Jul 27 '12 at 22:39
    
The node processor has a text format of "full html". Not sure why that doesn't work. –  Aaron Kreider Jul 27 '12 at 23:28
    
Seems to work properly if I do not use the default feed importer. Instead I created my own feed importer, I think with the exact same settings, and now it imports full html! –  Aaron Kreider Jul 28 '12 at 0:10
    
Thanks for posting the solution. You can post it as an Answer, then accept it. –  keva Jul 28 '12 at 3:20
add comment

1 Answer 1

Seems to work properly if I do not use the default feed importer. Instead I created my own feed importer, I think with the exact same settings, and now it imports full html!

share|improve this answer
    
It also might help to disable the existing feed importer in admin/structure/feeds. –  Aaron Kreider Aug 1 '12 at 20:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.