Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I'm using drush on mediatemple grid service. I think i've got setup drush correctly. At least to my knowledge. I've been able to use it; but with nagging errors/warnings each time.

And whenever i invoke drush i get these errors:

The following restricted PHP modes have non-empty values: check your configuration settings in /usr/local/php-5.2.14/etc/php.ini or in your drush.ini file

Anyone have any clues how to rectify this?

share|improve this question
    
Answer is actually found here: drupal.stackexchange.com/questions/10372/… –  chrisjlee Sep 28 '11 at 19:14

3 Answers 3

drush topic docs-ini-files

That command tells more about creating a drush.ini file. In it, you want to remove the listed restrictions (you didn't provide them).

share|improve this answer
up vote 0 down vote accepted

Setting an alias for drush allowed me to fix this issue:

alias drush='/usr/bin/php5 -c /home/000000/etc/drush.ini ~/bin/drush/drush.php'

share|improve this answer

Because making an alias for drush.php is not covered in drush-5.x Readme file. A better solution is to copy the server's default configuration php.ini file to $HOME/.drush or to /etc/drush.

Then, edit it to set open_basedir to no value and add any other custom configuration for crush.

Sample of drush specific php.ini file:

# Drush configuration
open_basedir=
safe_mode=
disable_functions=
disable_classes=
magic_quotes_gpc=

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.