Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I have a view with two page displays both of which share (defaults) an exposed filter block. I've set the exposed filters to show as a block on both displays. I think used the standard block UI to display the proper filter block on the proper URL for each page display.

However, now just the correct filter block shows twice on each of these two pages.

Cache extremely cleared.

share|improve this question
add comment

2 Answers 2

Try to switch to Garland theme to see if the problem still occurs, if not, it maybe a theme problem.

share|improve this answer
    
Still happens in Garland :( –  doublejosh Jun 30 '11 at 7:43
    
This is outputting via a Context Layout, so perhaps there is some insight in that issue queue. –  doublejosh Jun 30 '11 at 7:47
add comment
up vote 0 down vote accepted

The problem (in Context 3.0) is that the page was built via Context Layouts (which makes use of an alternate page.tpl.php template within that context) was conflicting with blocks placed via the core block UI.

Looks like currently if you're going to have a page build via Context Layout, you need to use content to place any blocks within the pages effected by that Layout.

I'm sure this will get fixed. Issue queue note: http://drupal.org/node/1204826

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.