Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I am trying to get a new Drupal site running on Ubuntu 12.10. I believe I have what is either an Apache or permissions error. I can get to the main logon page for the site, but after entering my credentials, I get the following error.

The website encountered an error while retrieving http://localhost/node?destination=node. It may be down for maintenance or configured incorrectly.

I set my permissions using the following script, and my apache setup is below that. Can anyone tell me where else to look?

!/bin/bash

FILES="/var/www/localdrupal/cms/sites/default/files"
SETTINGS="/var/www/localdrupal/cms/sites/default/settings.php"
SITES="/var/www/localdrupal/cms/sites"
DEFAULT="/var/www/localdrupal/cms/sites/default"
THEMES="/var/www/localdrupal/cms/sites/all/themes"
MODULES="/var/www/localdrupal/cms/sites/all/modules"
DSETTINGS="/var/www/localdrupal/cms/sites/default/default.settings.php"

# Paths for binary files
TAR="/bin/tar"
RM="/bin/rm"
CHOWN="/bin/chown"
FIND="/bin/find"
CHMOD="/bin/chmod"

# Change permissions to be secure

$CHOWN -R www-data:www-data ${SITES}
$CHMOD 775 ${SITES}
$CHMOD 775 ${FILES}
$CHMOD g+w -R ${FILES}
$CHMOD 440 ${SETTINGS}
$CHMOD 440 ${DSETTINGS}
$CHMOD 755 ${DEFAULT}
$CHMOD 755 -R ${THEMES}
$CHMOD 755 -R ${MODULES}

Apache:

    DocumentRoot /var/www/localdrupal/cms
    <Directory />
            Options FollowSymLinks
            AllowOverride  None
    </Directory>

    <Directory /var/www/localdrupal/cms/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
            Order allow,deny
            allow from all
    </Directory>
share|improve this question
    
Can you go to localhost/cms/node ? and try to login from there –  redhatlab Nov 20 '12 at 15:17
    
did you check if you have enable rewrite module for apache, also check if you have enable suphp, modsecurity, if you are running the right php version, you should check your logs in apache for more information. –  cayerdis Nov 20 '12 at 16:42

1 Answer 1

Check your setup.php, probably you should set the baseurl variable there, since your drupal root is not the default /var/www

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.