Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I have copied the database of my production site to my dev site and my theme is not working anymore (on the dev). The content (nodes) is not exactly the same, but theme folder is.

All the information in the CSS files is still displaying but the settings in admin/appearance/settings/corporateclean (UI for basic colors) have no effect anymore.

The logs show the following warning: Theme key "0" not found.

I have tried flusing the caches, de-activate cache pages, CSS aggregation without success. I had the issue in the past and copying all the files fixed it but it's a brute force fix and I'd like to understand what happens. I am 100% sure the theme directory is up to date, so some other files may be messing. Any idea?

share|improve this question
    
Are both sites running the same drupal version? –  Krister Andersson Nov 24 '12 at 18:32
    
Yes, they both run 7.14 –  NathanZ Nov 24 '12 at 21:09
    
Perhaps something has happend to your registry, try to rebuild it, read more here drupal.org/project/registry_rebuild –  Krister Andersson Nov 24 '12 at 21:29
1  
Thanks, I tried it but my registry was fine. I finally found the problem: the path to the custom logo was wrong, and when I fixed that it worked –  NathanZ Nov 24 '12 at 21:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.