Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

After migrating from Wordpress to Drupal with the Wordpress Migrate and Migrate modules, content still contains media tags:

[[{"type":"media","view_mode":"media_large","fid":"4202","attributes":[{"class":"media-image","typeof":"foaf:Image","style":"","width":"339","height":"305"}]}]]

What is the best way to strip them out?

share|improve this question

closed as too broad by kiamlaluno Nov 1 at 18:35

There are either too many possible answers, or good answers would be too long for this format. Please add details to narrow the answer set or to isolate an issue that can be answered in a few paragraphs.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

Ah found the answer after some digging:

You have the Media module enabled, so the migration renders image references as media tags - you need to change your filter to interpret the tags

http://drupal.org/node/1859458#comment-6819442

You have the Media module enabled, correct? And you're saying when you view (not edit) the nodes you're seeing the media embeds ([[{"type":"media"," etc.) instead of the image itself? Please go to /admin/config/content/formats and make sure that the text format you've chosen for the imported bodies has "Convert Media tags to markup" enabled.

http://drupal.org/node/1642352#comment-6136596

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.