Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I am tired of finding solution for this issue..

I have tried allmost allthings. But It doesn't work for me. What I have tried is given below:

  1. uncommenting RewriteBase /

  2. Changing the syntax of REWRITE URL

  3. No .txt extension in .htaccess file (EDITED)

  4. mod_rewrite Enabled.

  5. Directly removing the query string and giving enter also doens't work.

  6. If I include ALLOWOVERRIDES ALL in httpd.conf file it is showing Authentication Required Error.

  7. Tried disabling the overlay module - Doesn't work.

Here is the .htaccess file for your refernce.

#
# Apache/PHP/Drupal settings:
#

# Protect files and directories from prying eyes.
<FilesMatch "\.(engine|inc|info|install|make|module|profile|test|po|sh|.*sql|theme|tpl(\.php)?|xtmpl)$|^(\..*|Entries.*|Repository|Root|Tag|Template)$">
  Order allow,deny
</FilesMatch>

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# Follow symbolic links in this directory.
Options +FollowSymLinks

# Make Drupal handle any 404 errors.
ErrorDocument 404 /index.php

# Set the default handler.
DirectoryIndex index.php index.html index.htm

# Override PHP settings that cannot be changed at runtime. See
# sites/default/default.settings.php and drupal_environment_initialize() in
# includes/bootstrap.inc for settings that can be changed at runtime.

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
  php_flag magic_quotes_gpc                 off
  php_flag magic_quotes_sybase              off
  php_flag register_globals                 off
  php_flag session.auto_start               off
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_flag mbstring.encoding_translation    off
</IfModule>

# Requires mod_expires to be enabled.
<IfModule mod_expires.c>
  # Enable expirations.
  ExpiresActive On

  # Cache all files for 2 weeks after access (A).
  ExpiresDefault A1209600

  <FilesMatch \.php$>
    # Do not allow PHP scripts to be cached unless they explicitly send cache
    # headers themselves. Otherwise all scripts would have to overwrite the
    # headers set by mod_expires if they want another caching behavior. This may
    # fail if an error occurs early in the bootstrap process, and it may cause
    # problems if a non-Drupal PHP file is installed in a subdirectory.
    ExpiresActive Off
  </FilesMatch>
</IfModule>

# Various rewrite rules.
<IfModule mod_rewrite.c>
  RewriteEngine on

  # Block access to "hidden" directories whose names begin with a period. This
  # includes directories used by version control systems such as Subversion or
  # Git to store control files. Files whose names begin with a period, as well
  # as the control files used by CVS, are protected by the FilesMatch directive
  # above.
  #
  # NOTE: This only works when mod_rewrite is loaded. Without mod_rewrite, it is
  # not possible to block access to entire directories from .htaccess, because
  # <DirectoryMatch> is not allowed here.
  #
  # If you do not have mod_rewrite installed, you should remove these
  # directories from your webroot or otherwise protect them from being
  # downloaded.
  RewriteRule "(^|/)\." - [F]

  # If your site can be accessed both with and without the 'www.' prefix, you
  # can use one of the following settings to redirect users to your preferred
  # URL, either WITH or WITHOUT the 'www.' prefix. Choose ONLY one option:
  #
  # To redirect all users to access the site WITH the 'www.' prefix,
  # (http://example.com/... will be redirected to http://www.example.com/...)
  # uncomment the following:
  # RewriteCond %{HTTP_HOST} !^www\. [NC]
  # RewriteRule ^ http://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
  #
  # To redirect all users to access the site WITHOUT the 'www.' prefix,
  # (http://www.example.com/... will be redirected to http://example.com/...)
  # uncomment the following:
  # RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
  # RewriteRule ^ http://%1%{REQUEST_URI} [L,R=301]
  # RewriteCond %{HTTP_HOST} !^mysite\.com$ [NC]
  # RewriteRule ^(.*)$ http://mysite.com/$1 [L,R=301]

  # Modify the RewriteBase if you are using Drupal in a subdirectory or in a
  # VirtualDocumentRoot and the rewrite rules are not working properly.
  # For example if your site is at http://example.com/drupal uncomment and
  # modify the following line:
  # RewriteBase /drupal
  #
  # If your site is running in a VirtualDocumentRoot at http://example.com/,
  # uncomment the following line:
   RewriteBase /

  # Pass all requests not referring directly to files in the filesystem to
  # index.php. Clean URLs are handled in drupal_environment_initialize().
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_URI} !=/favicon.ico
  # RewriteRule ^ index.php [L]
  RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

  # Rules to correctly serve gzip compressed CSS and JS files.
  # Requires both mod_rewrite and mod_headers to be enabled.
  <IfModule mod_headers.c>
    # Serve gzip compressed CSS files if they exist and the client accepts gzip.
    RewriteCond %{HTTP:Accept-encoding} gzip
    RewriteCond %{REQUEST_FILENAME}\.gz -s
    RewriteRule ^(.*)\.css $1\.css\.gz [QSA]

    # Serve gzip compressed JS files if they exist and the client accepts gzip.
    RewriteCond %{HTTP:Accept-encoding} gzip
    RewriteCond %{REQUEST_FILENAME}\.gz -s
    RewriteRule ^(.*)\.js $1\.js\.gz [QSA]

    # Serve correct content types, and prevent mod_deflate double gzip.
    RewriteRule \.css\.gz$ - [T=text/css,E=no-gzip:1]
    RewriteRule \.js\.gz$ - [T=text/javascript,E=no-gzip:1]

    <FilesMatch "(\.js\.gz|\.css\.gz)$">
      # Serve correct encoding type.
      Header set Content-Encoding gzip
      # Force proxies to cache gzipped & non-gzipped css/js files separately.
      Header append Vary Accept-Encoding
    </FilesMatch>
  </IfModule>
</IfModule>

Any help will be really appreciated....

share|improve this question
    
What error message do you have? Is clean URL correctly activated in the drupal administration? –  Mika A. Dec 20 '12 at 15:19
    
Activation is in Administer > Configuration > Search and metadata –  Mika A. Dec 20 '12 at 15:25
    
I don't get the enable button there. I am just getting RUN the clean URL test button.. –  Fero Dec 20 '12 at 15:59
1  
Make sure you .htaccess file does not have a .txt extension. –  Justin Dec 20 '12 at 16:38
    
@@Justion: that'z i forget to add in the question.. first check is that only... –  Fero Dec 21 '12 at 14:06
add comment

2 Answers 2

up vote 4 down vote accepted

A good way to debug is to first see if your .htaccess is being picked up by Apache. My guess is that it is not, as the Drupal .htaccess should make clean URLs work out of the box with the rules that it ships with, supposing the mod_rewrite module is enabled.

To confirm this, however, make a blatant error in the .htaccess file and go to your Drupal home page, if the serving of the request failed (HTTP 500), it means that you are good to go and the problem is somewhere else.

If not, check if the directory from which your site is being served (i.e. your DocumentRoot) or one of its parents has AllowOverride All set. Basically, this is where you let the web server know that it should respect .htaccess overrides from the directories that it is serving from.

This might sound obvious but if you are running off a different web server (eg. nginx or IIS), you should know that you may have to configure it differently to get clean URLs to work.

share|improve this answer
    
+1 for advicing to check .htaccess file is picking up or not.. Wil check and get back asap.. Thanks.. –  Fero Dec 24 '12 at 9:07
add comment

The reason is because you have not uncommented the mod_rewrite line inside your httpd.conf. This is the most common setup error in apache. Navigate to your httpd.conf file (it is an apache file) and do a (ctrl+f) search for mod_rewrite. there should only be one instance. remove the # from the beginning and save. Restart apache and the check box should be there.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.