Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I'm using Google Webmaster Tools to manage my site SEO; even with 600 articles my total indexed pages is zero.

When I use "Fetch as Google" I get the following.

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html>
  <head>
    <title>302 Found</title>
  </head>
  <body>
    <h1>Found</h1>
    <p>The document has moved <a href="http://example.com">here</a>.</p> <hr />
  </body>
</html>

My site is made with Drupal 7, and the Boost module.

Is that caused by a wrong configuration? If so, how can I fix it?

share|improve this question
    
Have you tried to submit sitemap to Google? Try if this helps, also: drupal.org/project/xmlsitemap –  NenadP Jan 5 '13 at 17:11
    
yes of course,the site is verified and all my sitemaps are submitted to google –  mohammed amine bourkadi Jan 5 '13 at 17:22
    
Did you tried it without Boost? I tried to implement boost too, but ended up using Varnish cache (better imo, if you can) –  NenadP Jan 5 '13 at 17:42
    
@HoverFusion you say that maybe the Boost module is the source of the problem? –  mohammed amine bourkadi Jan 5 '13 at 20:38
    
@HoverFusion what do you mean by imo,and please give me your site url to take a look –  mohammed amine bourkadi Jan 5 '13 at 20:44
add comment

migrated from webmasters.stackexchange.com Dec 30 '12 at 1:13

This question came from our site for pro webmasters.

3 Answers

up vote 1 down vote accepted

It looks like you have a different domain either registered or for testing with Google Webmaster Tools.

e.g example.com vs www.example.com

When the bot requests example.com, it is redirected to www.example.com with an HTTP 302 Found reponse.

The solution would be to register the same preferred domain with Google Webmaster Tools that is used for regular site visitors.

As for 0 pages of a new site being indexed in Google, give it time. If you've registered the sitemap, and signed up for Google Analytics, the googlebot will arrive soon. It can take a couple of weeks.

share|improve this answer
    
For the 302 found i will give you an ansewer afetr testing it,and for the 0 page my website is 4 months old –  mohammed amine bourkadi Jan 6 '13 at 2:03
    
I've seen it take up to 6 months before for Google indexing to occur. It tends to be shorter these days though. Test the index also by searching site:example.com in Google. –  David Thomas Jan 6 '13 at 2:15
    
In Webmastertools->Configuration->Setting->Preffered domain my own preffered domain is not set "Don't set a preferred domain" and when i try to change it to www.example.com or just example.com i get the following messgae: "Part of the process of setting a preferred domain is to verify that you own sahara-question.com. Please verify sahara-question.com/."; what does it mean?and how to fix that? thank you very much –  mohammed amine bourkadi Jan 6 '13 at 2:20
    
You need to go through the verification process with the new adjusted domain. The instructions are explained in Google Webmaster Tools. –  David Thomas Jan 6 '13 at 5:35
    
Did you mean i delete my old site account in google webmaster tools and recreate another one –  mohammed amine bourkadi Jan 6 '13 at 12:35
add comment

No you don't have to recreate a new account for your site on google weblaster tools,just wait for few days or weeks and it will be ok . For the boost some make sure that your boost code gotten from the module generator is well copied before

RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_URI} !=/favicon.ico RewriteRule ^ index.php

test it and everything will be ok

share|improve this answer
add comment

I found the ansewer:
It's the Boost module,i had misconfigured it, i should put the Boost code above this line not under it:

RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_URI} !=/favicon.ico RewriteRule ^ index.php [L

For more details please see this post: http://drupal.org/node/1881070

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.