Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I have installed the Facebook Share module on my Drupal 7 site and configured it accordignly to my preferences but it is not showing up on any of the pages I chose.

I just tested it even further by choosing it to be displayed every (full) node and it is showing up on basic pages, faq, and some more but not on my Ubercart products and one custom content type. It does show up on another custom content type.

Any ideas?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

I realize this isn't exactly an answer to how to get Facebook Share on all of your pages, but I figured I would toss this out there as a possible alternate solution.

I've tested a lot of the different sharing modules and I would recommend Service Links instead of Facebook Share. I've found it to be highly configurable, very flexible and it just works really really well. You may want to give it a try, perhaps it'll show up properly in the places you want it to show up.

share|improve this answer
    
Thank you for your answer. I installed it and tried it out. It seems a really useful module. It could work for my case but the thing is that the specifications are strictly set by our clients (that means that I may have to do some modifications). I'll keep it as a back-up solution in case I'm unable to resolve the issue with the facebook share module –  Voullage Jan 6 '13 at 19:09
    
I feel you. I'm always having to do those kinds of things to satisfy the client. –  Kenny Wyland Jan 6 '13 at 20:03
    
I am using service links too, but it lacked Facebook Share capabilities. Ill check if something changed, because i like service links too. –  NenadP Jan 14 '13 at 20:07

I was finally able to resolve the problem. Just posting the solution in case it comes useful to anyone else.

As it turned out, the problem with Facebook share was display suite. The nodes that it was not working for were, of course, not random as it initially looked. They were the nodes which were using display suite. I didn't manage to find a solution to it and therefore I used the service links module (proposed by @Kenny Wyland), which had an extra feature covering the case that display suite is being used.

share|improve this answer

You can try to enable it directly in template php files (for example node.tpl.php) by using

<?php hide($content['facebookshare']); ?>

And then later in tpl, where you want button to appear:

<?php print render($content['facebookshare']);?>

Also make sure you eneble it for specific content type here:

/admin/config/user-interface/facebookshare

Also, other fb modules may be conflicting it if you have them.

share|improve this answer
    
I'm afraid the first option is not working. I am getting a messed up page when I include this line of code. It could be conflicting with another module (I have no other fb modules installed though) but why would it only conflict on certain content types? –  Voullage Jan 5 '13 at 16:16
    
See the answer update. Otherwise, strange. Method which i mentioned is one i use on my site and it works. Try seeing into your php/drupal log for clues... –  NenadP Jan 5 '13 at 17:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.