Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I am getting "page no found" errors in my website log. Maybe it is some bots that search for directories that do not actually exist. I get at least 50-100 daily of these messages.

The log says, for example:

www.mysite.com 46.29.3.237 - - [14/Jan/2013:17:02:33 +0100] "GET /files HTTP/1.1" 200 683 "-" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.52 Safari/537.17"

How is it possible to get rid of that? I am just worried if there is problem on my side or it happens to any site. Thank you.

share|improve this question
    
What do you mean by, "get rid of that"? Are you asking for a way to remove those messages, or a way to avoid those messages are logged? –  kiamlaluno Jan 14 '13 at 20:22
    
Something is wrong with your setup. That particular URL is returning a HTTP status code of 200, which means the URL was valid. –  MPD Jan 14 '13 at 20:26

1 Answer 1

up vote 1 down vote accepted

It's very likely automated programs looking to see if you have the proper restrictions on certain directories.

There's no way to prevent it from happening, but you could either turn off 404 logging or have your server log 404 errors to a different file.

share|improve this answer
    
Ok , I just needed to know if that is normal and there is nothing to worry about. Thank you. –  loparr Jan 14 '13 at 20:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.