Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I'm trying to work through this UUID features bug with the deploy module. On the receiving site, I see errors in that log like

PDOException: SQLSTATE[HY000]: General error: 1366 Incorrect integer value: 'fc661e5c-62de-fa34-2557-0f6f5a2acbfe' for column 'fid'

I've followed the example laid out here to have a backtrace show for any error on both the sending and receiving installations. However I can' seem to find a way to get the backtrace to show for the error on the receiving site after the deploy process completes. I can see the service error in /admin/reports/dblog but that's it.

Any help is greatly appreciated!

-adbo

share|improve this question
add comment

1 Answer

note the following: fc661e5c-62de-fa34-2557-0f6f5a2acbfe and then... General error: 1366 Incorrect integer value:

the number or UUID is not an integer.

therefore you'll get that sort of error message. I'm assuming deploy has either a bug in it or you've forgotten to run update.php on your DB the FID field is marked in the DB as an integer when it should be a varchar / string field.

Take a look at the schema and see what needs to change. that should at least give you an indication of where things have gone wrong.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.