Take the 2-minute tour ×
Drupal Answers is a question and answer site for Drupal developers and administrators. It's 100% free, no registration required.

I am getting the following error after uploading files in server:

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

For development purposes, I am using the following server URL: http://dev.example.mhd.co.us.

I am not able to access site when it has its .htaccess file; when I remove the .htacess file, it works fine. I am using the default file that comes with Drupal. I need to enable the clean URLs on the site.; mod_rewrite is enabled.

Is there anything else I need to configure? Do you have any idea about why I have problems?

share|improve this question

closed as too localized by kiamlaluno Dec 25 '12 at 8:23

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Can you please share your .htaccess here ? –  Nikhil M Nov 25 '12 at 13:52

3 Answers 3

That usually means something in your .htaccess is causing Apache to fail. Could for example be a missing module or a configuration that denies access to something.

Try to look at the error log of the Apache server, if you have access to it. If not (even many shared hosting sites allow access to those files for your virtual host), you could ask your hosting provider support.

It is only possible to provide a more detailed solution once you post the actual error from the error log.

share|improve this answer
    
Thanks for your suggestion.Is any-other way to read apache configurations which are enabled in server through php code,like phpinfo(). –  Nithish Jun 30 '11 at 8:52
    
No, I don't think so. Again, check your logs. Everything else is just blindly guessing. Once you can provide the actual error message from the log, this should be much easier to resolve. –  Berdir Jun 30 '11 at 15:24

This error is due to .htaccess syntax error. Restore your .htaccess

For enabling Clean URLs you must have mod_rewrite enabled.

Make sure if RewriteEngine On in .htaccess

Setting .htaccess for Drupal that is extracted on the www-root. (e.g. example.com/) Uncomment the following line from .htaccess:

RewriteBase /

If Drupal is extracted in sub directory (e.g. example.com/subdir/)

RewriteBase /subdir/

share|improve this answer
    
Thanks for ur reply.It didn't work's for me.If i place a single code throwing internal error. –  Nithish Jun 30 '11 at 8:44

Have you run Drupal on this host before (or even Wordpress)? I have run into hosting companies that disable a lot of the directives in the standard Drupal .htaccess file, and this can cause Apache to throw 500 errors.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.