4 edited tags; edited tags
| link
3 [Edit removed during grace period]
source | link
2 Added appropriate clean-urls tag, fixed spelling and improved formatting
source | link

Clean URLs enablesenabled but main-menu keeps replacing clean urlURL with ugly node/ urlURL

I have enabled clean url'sURL's on my applicationwebsite and had a menu item in my main-menu that pointed to a viewView that had a urlURL alias set up for /ebook-register. I just removed that alias and setassigned the same alias up forto a page (content item). However now the menu item keeps getting set to node/2 instead of ebook-register. How can I get the menu to stop changing my Cleanclean URL into uglynessugliness? If I manually navigate to localhost/ebook-register I get to the right page, and under URL aliases in the admin I can see the alias and confirmed it's pointing to the correct page, and the menu doesn't throw an error when I set ebook-register to the path so it's finding the alias.

It does give me the following message "The menu system stores system paths only, but will use the URL alias for display. ebook-register has been stored as node/2".:

The menu system stores system paths only, but will use the URL alias for display. ebook-register has been stored as node/2.

However, despite saying it will display the clean urlURL, clicking the link sends you to the ugly node/2 urlURL.

I am using Drupal 7 and have tried clearing the cache already.

Clean URLs enables but main-menu keeps replacing clean url with ugly node/ url

I have enabled clean url's on my application and had a menu item in my main-menu that pointed to a view that had a url alias set up for /ebook-register. I just removed that alias and set the same alias up for a page (content item). However now the menu item keeps getting set to node/2 instead of ebook-register. How can I get the menu to stop changing my Clean URL into uglyness? If I manually navigate to localhost/ebook-register I get to the right page, and under URL aliases in the admin I can see the alias and confirmed it's pointing to the correct page, and the menu doesn't throw an error when I set ebook-register to the path so it's finding the alias.

It does give me the following message "The menu system stores system paths only, but will use the URL alias for display. ebook-register has been stored as node/2". However despite saying it will display the clean url clicking the link sends you to the ugly node/2 url.

I am using Drupal 7 and have tried clearing the cache already.

Clean URLs enabled but main-menu keeps replacing clean URL with ugly node/ URL

I have enabled clean URL's on my website and had a menu item in my main-menu that pointed to a View that had a URL alias set up for /ebook-register. I just removed that alias and assigned the same alias up to a page (content item). However now the menu item keeps getting set to node/2 instead of ebook-register. How can I get the menu to stop changing my clean URL into ugliness? If I manually navigate to localhost/ebook-register I get to the right page, and under URL aliases in the admin I can see the alias and confirmed it's pointing to the correct page, and the menu doesn't throw an error when I set ebook-register to the path so it's finding the alias.

It does give me the following message:

The menu system stores system paths only, but will use the URL alias for display. ebook-register has been stored as node/2.

However, despite saying it will display the clean URL, clicking the link sends you to the ugly node/2 URL.

I am using Drupal 7 and have tried clearing the cache already.

1
source | link