3 edited tags
| link
2 clarify
source | link

I first ran the install.php when drupal was reachable as example.org/drupal/, then later I changed the Apache configuration to make it into a virtual host. Now that I can reach the site at example.org, the problem is, all links available on that page still have /drupal/ in them, and result in 404.

I have tried uncommenting "RewriteBase /" in the .htaccess file, and restarting Apache. Nothing changed. There is nothing of use in the settings.php file for the site.

There are a lot of web pages that seem to solve this, but they are either for older versions of Drupal or just don't work.

I can force the correct URL's down Drupal's throat with an additional rule in the Apache configuration to rewrite the URL without the /drupal/ link, but come on, there must be a less hackish way to fix this.

Also of note, I'm trying this out on Arch Linux, so some file paths might be different. But this is a configuration issue, not a file path issue.

EDIT: for clarity, what I want is all links to show as example.org/blah without the /drupal/ being automatically inserted.

I first ran the install.php when drupal was reachable as example.org/drupal/, then later I changed the Apache configuration to make it into a virtual host. Now that I can reach the site at example.org, the problem is, all links available on that page still have /drupal/ in them, and result in 404.

I have tried uncommenting "RewriteBase /" in the .htaccess file, and restarting Apache. Nothing changed. There is nothing of use in the settings.php file for the site.

There are a lot of web pages that seem to solve this, but they are either for older versions of Drupal or just don't work.

I can force the correct URL's down Drupal's throat with an additional rule in the Apache configuration to rewrite the URL without the /drupal/ link, but come on, there must be a less hackish way to fix this.

Also of note, I'm trying this out on Arch Linux, so some file paths might be different. But this is a configuration issue, not a file path issue.

I first ran the install.php when drupal was reachable as example.org/drupal/, then later I changed the Apache configuration to make it into a virtual host. Now that I can reach the site at example.org, the problem is, all links available on that page still have /drupal/ in them, and result in 404.

I have tried uncommenting "RewriteBase /" in the .htaccess file, and restarting Apache. Nothing changed. There is nothing of use in the settings.php file for the site.

There are a lot of web pages that seem to solve this, but they are either for older versions of Drupal or just don't work.

I can force the correct URL's down Drupal's throat with an additional rule in the Apache configuration to rewrite the URL without the /drupal/ link, but come on, there must be a less hackish way to fix this.

Also of note, I'm trying this out on Arch Linux, so some file paths might be different. But this is a configuration issue, not a file path issue.

EDIT: for clarity, what I want is all links to show as example.org/blah without the /drupal/ being automatically inserted.

1
source | link

How to get drupal to remove /drupal/ from all the links on the website

I first ran the install.php when drupal was reachable as example.org/drupal/, then later I changed the Apache configuration to make it into a virtual host. Now that I can reach the site at example.org, the problem is, all links available on that page still have /drupal/ in them, and result in 404.

I have tried uncommenting "RewriteBase /" in the .htaccess file, and restarting Apache. Nothing changed. There is nothing of use in the settings.php file for the site.

There are a lot of web pages that seem to solve this, but they are either for older versions of Drupal or just don't work.

I can force the correct URL's down Drupal's throat with an additional rule in the Apache configuration to rewrite the URL without the /drupal/ link, but come on, there must be a less hackish way to fix this.

Also of note, I'm trying this out on Arch Linux, so some file paths might be different. But this is a configuration issue, not a file path issue.