3 removed tags from the title
| link

Page Redirect Rulerule doesn't contain all the query parameters

2 added 12 characters in body
source | link

I`ve set up a Rule to redirect a user after log in. The Rule works redirecting the user to the URL specified, but it doesn't contain all the query parameters after "?".

This is the URL value:

user/login?destination=node/4?cid1=[entity-fetched-household:0:contact-id]&cs1=[entity-fetched-household:0:hash]&cid2=[account:civicrm-contact:contact-id]&cs2=[account:civicrm-contact:hash]

But the user is redirected to the following one:

user/login?destination=node/4?cid1=[entity-fetched-household:0:contact-id]

just containing the first query parameter cid1.

I've checked the other parameters, cs1, cid2, cs2, contain the correct values.

This is the export of the Rule:

{ "rules_add_parameters_to_url_related_to_contact_id" : {

{ "rules_add_parameters_to_url_related_to_contact_id" : {

"LABEL" : "Add parameters to url related to contact id",
"PLUGIN" : "reaction rule",
"OWNER" : "rules",
"REQUIRES" : [ "rules", "path" ],
"ON" : { "user_login" : [] },
"DO" : [
  { "entity_query" : {
      "USING" : {
        "type" : "civicrm_contact",
        "property" : "display_name",
        "value" : [ "account:civicrm-contact:household-name" ],
        "limit" : "1"
      },
      "PROVIDE" : { "entity_fetched" : { "entity_fetched_household" : "Fetched entity" } }
    }
  },
  { "redirect" : { "url" : "user\/login?destination=node\/4?cid1=[entity-fetched-household:0:contact-id]\u0026cs1=[entity-fetched-household:0:hash]\u0026cid2=[account:civicrm-contact:contact-id]\u0026cs2=[account:civicrm-contact:hash]" } },
]
  }
}

} }

Any help will be really appreciated.

I`ve set up a Rule to redirect a user after log in. The Rule works redirecting the user to the URL specified, but it doesn't contain all the query parameters after "?".

This is the URL value:

user/login?destination=node/4?cid1=[entity-fetched-household:0:contact-id]&cs1=[entity-fetched-household:0:hash]&cid2=[account:civicrm-contact:contact-id]&cs2=[account:civicrm-contact:hash]

But the user is redirected to the following one:

user/login?destination=node/4?cid1=[entity-fetched-household:0:contact-id]

just containing the first query parameter cid1.

I've checked the other parameters, cs1, cid2, cs2, contain the correct values.

This is the export of the Rule:

{ "rules_add_parameters_to_url_related_to_contact_id" : {

"LABEL" : "Add parameters to url related to contact id",
"PLUGIN" : "reaction rule",
"OWNER" : "rules",
"REQUIRES" : [ "rules", "path" ],
"ON" : { "user_login" : [] },
"DO" : [
  { "entity_query" : {
      "USING" : {
        "type" : "civicrm_contact",
        "property" : "display_name",
        "value" : [ "account:civicrm-contact:household-name" ],
        "limit" : "1"
      },
      "PROVIDE" : { "entity_fetched" : { "entity_fetched_household" : "Fetched entity" } }
    }
  },
  { "redirect" : { "url" : "user\/login?destination=node\/4?cid1=[entity-fetched-household:0:contact-id]\u0026cs1=[entity-fetched-household:0:hash]\u0026cid2=[account:civicrm-contact:contact-id]\u0026cs2=[account:civicrm-contact:hash]" } },
]

} }

Any help will be really appreciated.

I`ve set up a Rule to redirect a user after log in. The Rule works redirecting the user to the URL specified, but it doesn't contain all the query parameters after "?".

This is the URL value:

user/login?destination=node/4?cid1=[entity-fetched-household:0:contact-id]&cs1=[entity-fetched-household:0:hash]&cid2=[account:civicrm-contact:contact-id]&cs2=[account:civicrm-contact:hash]

But the user is redirected to the following one:

user/login?destination=node/4?cid1=[entity-fetched-household:0:contact-id]

just containing the first query parameter cid1.

I've checked the other parameters, cs1, cid2, cs2, contain the correct values.

This is the export of the Rule:

{ "rules_add_parameters_to_url_related_to_contact_id" : {

"LABEL" : "Add parameters to url related to contact id",
"PLUGIN" : "reaction rule",
"OWNER" : "rules",
"REQUIRES" : [ "rules", "path" ],
"ON" : { "user_login" : [] },
"DO" : [
  { "entity_query" : {
      "USING" : {
        "type" : "civicrm_contact",
        "property" : "display_name",
        "value" : [ "account:civicrm-contact:household-name" ],
        "limit" : "1"
      },
      "PROVIDE" : { "entity_fetched" : { "entity_fetched_household" : "Fetched entity" } }
    }
  },
  { "redirect" : { "url" : "user\/login?destination=node\/4?cid1=[entity-fetched-household:0:contact-id]\u0026cs1=[entity-fetched-household:0:hash]\u0026cid2=[account:civicrm-contact:contact-id]\u0026cs2=[account:civicrm-contact:hash]" } },
]
  }
}

Any help will be really appreciated.

1
source | link

Page Redirect Rule doesn't contain all the query parameters

I`ve set up a Rule to redirect a user after log in. The Rule works redirecting the user to the URL specified, but it doesn't contain all the query parameters after "?".

This is the URL value:

user/login?destination=node/4?cid1=[entity-fetched-household:0:contact-id]&cs1=[entity-fetched-household:0:hash]&cid2=[account:civicrm-contact:contact-id]&cs2=[account:civicrm-contact:hash]

But the user is redirected to the following one:

user/login?destination=node/4?cid1=[entity-fetched-household:0:contact-id]

just containing the first query parameter cid1.

I've checked the other parameters, cs1, cid2, cs2, contain the correct values.

This is the export of the Rule:

{ "rules_add_parameters_to_url_related_to_contact_id" : {

"LABEL" : "Add parameters to url related to contact id",
"PLUGIN" : "reaction rule",
"OWNER" : "rules",
"REQUIRES" : [ "rules", "path" ],
"ON" : { "user_login" : [] },
"DO" : [
  { "entity_query" : {
      "USING" : {
        "type" : "civicrm_contact",
        "property" : "display_name",
        "value" : [ "account:civicrm-contact:household-name" ],
        "limit" : "1"
      },
      "PROVIDE" : { "entity_fetched" : { "entity_fetched_household" : "Fetched entity" } }
    }
  },
  { "redirect" : { "url" : "user\/login?destination=node\/4?cid1=[entity-fetched-household:0:contact-id]\u0026cs1=[entity-fetched-household:0:hash]\u0026cid2=[account:civicrm-contact:contact-id]\u0026cs2=[account:civicrm-contact:hash]" } },
]

} }

Any help will be really appreciated.