0

I am creating an install profile that requires, among other things, a slew of Features. Because of the intricacies of the project, which is a multi-site, I have in sites/mysite.com/modules/custom_features 3 different categories of features, each in its own folder: my_install_profile/, my_other_install_profile/, and common/.

Drupal seems to be finding all of the modules that my install profile requires just fine, except one. It's expecting to find it in sites/mysite.com/modules/custom_features/my_install_profile/ but the module actually lives in sites/mysite.com/modules/custom_features/common/.

I've triple-checked the install profile, and any dependent modules. I can't find anything path-specific, or specific to this module, that might be causing the confusion.

It doesn't report that the module is missing at the beginning of installation, but partway through I get this:

Warning: include_once(umn_import_content_type.features.inc) [function.include-once]: failed to open stream: No such file or directory in include_once() (line 7 of /www/sites/mysite.com/modules/custom_features/my_install_profile/my_feature/my_feature.module).

Warning: include_once() [function.include]: Failed opening 'my_feature.features.inc' for inclusion (include_path='.:/Applications/MAMP/bin/php/php5.3.14/lib/php') in include_once() (line 7 of /www/sites/mysite.com/modules/custom_features/my_install_profile/my_feature/my_feature.module).

Why is Drupal looking for this in the wrong folder?

1

It appears that the issue was at the infrastructure level. The error resolved when I restarted Apache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.