1

I'm trying to move a drupal 7 install from one server to the other. I'm able to move the files and export/import the database fine. After tweaking settings and clearing caches the site displays fine. All links work, all paths work.

The only problem I'm having is that I've got a custom content type with an image field. The image field is showing up as a field under the "manage fields" tab, but the type of field is not displaying.

Also I cannot use this field in any views or in the theme at all.

All of the data for the field is there, and it seems like everything is joined in the db correctly, but that could be the issue. I've checked permissions and php settings compared to the old server and everything seems consistent.

I have no idea what to even look for to troubleshoot. I tried running a test using the testing module against the image module but that wouldn't run either. It gave me the error "Attempt to create a field of unknown type"

I've also run cron, purged caches, re-run the data transfer, and tried to update the fields through admin. I've also checked all modules and just updated everything I can find in drupal. Nothing is working.

Any ideas on other things I can try or look to to try to troubleshoot this? I'm at a loss at this point.

  • to expand on this a bit, it appears that the Image field type is not available. No idea why. Modules are enabled. – jccone Jan 16 '14 at 20:05
  • Maybe GD is not installed on the new server? Did you check the status report? – berliner Jan 17 '14 at 8:10
  • My thoughts as well. GD and ImageMagick were set up. – jccone Jan 17 '14 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.