9

My question title says it all.

I have feeds for importing and tamper for editing the data before being put into my nodes.

I have my values delimited by commas and explode is making them into individual values. I've made sure of this by also assigning them to individual text fields.

The exploded values are not getting assigned to already created taxonomy terms. I've noticed that there are spaces in front of all terms except the first and after all terms except the last. I've tried to add additional options like trim or exact. Neither have had any affect.

To simplify things, I've removed all but one taxonomy terms and removed all spaces before and after commas from the .csv file. Still nothing shows up into my term field when I explore.

Additional I've tried to use the search term by name add-on for feeds, but it gives me a query error.

Since I'm obviously missing a step, I'm curious how to set up each step of the puzzle.

Content type field set up, mapping to the term reference field, and finally the tamper set up. Since mapping is fairly straight forward I'm only concerned with getting multiple taxonomy terms attached to the nodes I am trying to import.

I'm hoping to avoid trial and error of every combination of settings here as such, any and all help provided is appreciated.

  • Is the taxonomy field a "tag" type that allows comma separated text when creating a node? Or is it a select list when creating a content type? – 2pha Jan 17 '14 at 4:00
  • My content type inventory has a field called "category" which is the target for my imported column called "category". This column was also used to create taxonomy terms out of. So the field is called "Category" field name is "field_category", Field type "Term reference", Widget "Autocomplete term widget (tagging)" the widget allows multiple values. The term reference is attached to vocabulary "imported inventory". – user25361 Jan 17 '14 at 4:03
  • I understand that, but is the taxonomy field a "tag" type which allows for new terms to be created on node creation? – 2pha Jan 17 '14 at 4:06
  • I'm not attempting to create new taxonomy terms. I simply want to attach the nodes to existing terms . Am i going about this the wrong way? I don't have an option to make a field of type "tag" only term reference and attach it to a specific vocabulary. – user25361 Jan 17 '14 at 4:08
  • If I'm not answering your question well enough in order for you to help me, please try again. I'd like to solve this and move on. – user25361 Jan 17 '14 at 4:15
11

You just set Search taxonomy terms by: Term name in mapping at Node processor & uncheck Auto create.

Add explode plugin at Feed Tamper tab with string operator such as ||.

Provide multiple value separated by your set string operator and it will work. It works for me at several places.

  • What do i set the taxonomy field in the content type as? I have list, check box or auto complete. – user25361 Jan 17 '14 at 18:07
  • I have autocomplete in my content type for taxonomy. – RajeevK Jan 18 '14 at 9:46
  • To clarify the initial step here, you first go through the normal motions of adding a mapping ( [csv heading] -> [drupal field]). After you have done that you will see an additional configuration Search taxonomy terms by: Term name. – doub1ejack Mar 17 '14 at 20:29
  • This isn't working for me. I can't get commerce feeds to assign taxonomy terms to the product display. The terms are already imported. – DraganAscii Jan 16 '18 at 15:17
0

Here are a couple of screenshots to demonstrate settings:

First step

Second step

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.