0

I have Installed Drupal 7.26 (Default Installation), and on a Fresh Installation, I have Views Module (CTools All Sub Modules Installed) and PathAuto Module installed ONLY. OK, So I create a Content Type and delete the Body Field that is created by default, and create another Field called Section and have it set to LONG TEXT, than make it filterable in the settings so that the user can select the text format, and have it set to an UNLIMITED amount of areas, with required UNCHECKED.

I than create 1 node using this content type with FULL HTML selected as the text format for each section and save it.

I now go to the Views Module and attempt to use an Unordered List, of Fields and select Content: Section as the field, The formatter is set to Default, I set a filter on it for Content Type and select Is One of That content types name. I see nothing in the preview at the bottom and so I go ahead and save it anyways as it should show something. I have the page path set to node so that it shows up on the front page. However, there is nothing being returned for the output of this view on the Front Page.

No matter what theme I choose, I can not get HTML to output in this view whatsoever.

Is there some sort of settings I have not performed somewhere? I go to Reports -> Status and everything checks out fine. All Green sections there. I go to run Cron, again, no problems whatsoever so it seems. How to debug this? Or is this an actual confirmed bug in Views? Or Drupal? Or something else?

If I change the type from Fields to Content, it still shows no body content, but now only shows the Title of the Content and links to the Page where it is located at, but on that page, it shows nothing but the title. How can this be fixed? OMG, this is a nightmare. I've been trying to hunt down the problem for days with no luck at all!

  • remove contextual filter and check again – M a m a D Jan 17 '14 at 6:56
  • There are no contextual filters defined at all. – Solomon Closson Jan 17 '14 at 7:01
  • sorry I meant filter criteria, create a new view of type YOUR_CONTENT_TYPE in this way no filter criteria is needed and add another all the fields of the content type – M a m a D Jan 17 '14 at 7:03
  • Yes, Nothing shows for the Content: Section field except for commas. I get a comma for each section in that field minus 1. – Solomon Closson Jan 17 '14 at 7:23
  • well, instead of a long text, simply pick up an integer as fields type. try to change different factor for example set number of values to 1. – M a m a D Jan 17 '14 at 7:44
0
  • "node" is registered menu path by node module
  • You should not set a page path "node" which already exists.
  • Create a block view using views instead of page view
  • Enable the block on home page
  • I did this and now I get nothing but commas showing... Content: Section shows commas. The output is this , , , , , One for every section in that node that I added. The only other type of section in the list is delta. Is there something wrong with the settings here? – Solomon Closson Jan 17 '14 at 6:44
  • Can you edit your node and verify content is present ? – Anil Sagar Jan 17 '14 at 6:53
  • Yes, when I go to edit the node, I see all 6 sections in there as FULL HTML, but strange when I go to actually view the node, I see only the first section in the actual viewing of the node. – Solomon Closson Jan 17 '14 at 7:02
  • Ok, so I cleared the cache again, but now I see NO sections at all when viewing the actual node itself, which has a path defined for it that is the actual title of the node. The title shows up on that page, but no content at all. But there definitely IS content in the field when I go to edit it. I go to Structure -> Manage Display and have Label hidden, and content set to Default, it is set to Full Content, and that is set to Label Hidden, and content set to Default as well. What's wrong here? – Solomon Closson Jan 17 '14 at 7:17
  • This is unbelievable! I don't believe that this isn't working for me! It's just me... just my luck! Happens to me all of the time! I've been trying to figure this out for days now! Unbelievable! – Solomon Closson Jan 17 '14 at 7:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.