2

I am new to drupal , I have installed SEARCH API . I have opened an account with open solr and following the process suggested in https://drupal.org/node/2137651
since I am not using apache solr search I am going to search api setting (last para in help ) the setup was succesfful and I was able to connect to solr server and infact was able to delete the index , However I am geeting the error message in config->search api->server as" You are using an incompatible schema.xml configuration file. Please follow the instructions in the INSTALL.txt file for setting up Solr" I am also not able to index , it gives error 400 I dont know where I went wrong in follwing document of https://drupal.org/node/2137651 .I also copied the schema.xml from (open solr ) to drupal/sites/all/modules/search_api_solr/solr-conf/4.x

Any help is highly appreciated Regards Carol

3

Copy the schema.xml from the Search API Solr module into Open Solr. Also be warned that compatibility with 4.x is not stable, so consider using solr 3.x configuration instead.

0

I also copied the schema.xml from (open solr ) to drupal/sites/all/modules/search_api_solr/solr-conf/4.x

You have to copy all the configuration files from "drupal/sites/all/modules/search_api_solr/solr-conf/4.x" to your conf directory of the solr core (eg. "$SOLR_HOME/collection1/conf").

0

I was having the same issue, and receiving the "Please follow the instructions in the INSTALL.txt file for setting up Solr". The solution was to install apache Solr manually, following this tutorial https://www.digitalocean.com/community/tutorials/how-to-install-solr-on-ubuntu-14-04. After that everything went well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.