0

I'm trying to make a Gallery utilizing lightbox on my Drupal 7.26 site. I've picked Media Gallery (7.x-1.0-beta8) and as it says it requires the following compulsory components to work:

  • Media (1.4)
  • Multiform (1.0)
  • ColorBox jQuery plugin

I've extracted a colorbox-master.zip under sites/all/libraries and renamed colorbox-master folder to colorbox. Now the sites/all looks like this.

showing locations of various modules/libraries

I also have the colorbox module installed.

The images in the gallery doesn't seem to use any lightbox at all when clicked upon. I've checked a couple of other solutions elsewhere and I think I've gotten all of them covered as you can see on the screenshot above. Nothing else seems to help.

What am I doing wrong?

2
  • 1
    Check the colorbox folder/file permissions in libraries. I had a simillar issue in loading the CkEditor. Jan 24 '14 at 6:40
  • Thanks! Giving sites/all/libraries/colorbox full read/write permission solved the issue. Jan 24 '14 at 6:46
0

As Bala Varadarajan suggested. I gave sites/all/libraries/colorbox/ and all its contents full Read/Write permissions.

The lightbox is working now.

2
  • Perhaps you could let Bala Varadarajan create the answer for this question as he actually answered this for you in the comments and then you can upvote and accept their answer to give him credit for his efforts to help you. Jan 24 '14 at 9:04
  • 1
    He is welcome to do so. If in two days I find his answer I will always upvote and approve that over mine. Jan 24 '14 at 10:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.