0

Problem

I'm using Entity Translate for the multi-lingual parts of my site, this allows me to use the language switcher. (I've enabled it for content, and then on the content type I've enabled field translation).

However the node body is not translatable.

Do I need to create a field and use that as the body, or have I set-up entity translation badly?

1

Ah turns out you have to enable translation for the field once you've enabled translation for the content type.

Open up your content type, edit the field you want to make translatable then head down to the bottom of the page.

You should see something like:

Field translation Users may translate all occurrences of this field:

  • Body in Basic page

  • Body in Article

  • Body in Webform

  • Body in Test Content

  • Body in Upgrade & Search Token Product Display

  • Body in Blog post/Article

  • Body in Development Blog

Click on "Enable translation" and you're good to go.

  • What's that link in your answer? – berliner Jan 28 '14 at 22:25
  • Just some random letters, in Drupal it's an admin path, but it looks like a link. So to give it formatting to match the real one I just added a random link. Hmm perhaps that's confusing. – Dominic Woodman Jan 28 '14 at 22:49
  • Totally, remove it please. – berliner Jan 28 '14 at 22:53
  • Cheers for that! – Dominic Woodman Jan 29 '14 at 2:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.