0

I have an exposed filter for a taxonomy vocabulary. The filter settings are

  • Single Filter
  • Operator: Is one of
  • Limit list to selected items: On
  • Selected vocabulary terms: a subset of the full, flat (non-hierarchal) vocabulary
    • Assume selected terms term1, term2, term3
    • Assume non selected terms non1, non2, non3

The filters UI appears and is accurate, and it is functional when a filter is selected. However, when the - Any - option is selected, all objects from the vocabulary are displayed - all of the term# objects are displayed along with the non# objects.

I've tried adding a second (non-exposed) filter that does is one of for each of the term# terms. With this, the - Any - option is correct but none of the other selected filters in the drop down work.

How do I get only the selected term# elements to show when the - Any - option is selected?

1

For the second non-exposed filter change the operator to is none ofand assign the terms accordingly (inverse to what you have now). If not otherwhise specified filters in views are AND filters.

  • You're my hero. What's your address? I'll mail you a beer ;) – Jeff Feb 4 '14 at 21:29
  • You're very welcome! – berliner Feb 4 '14 at 23:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.