1

I cannot seem to get rid of this error after numerous updates, anyone got any ideas/advice how to fix it as my Admin Modules doesn't want to load at all. I'm running D7.26 on this project. Thanks.

Reports as:

PDOException: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'has_children' in 'field list': UPDATE {menu_links} SET menu_name=:db_update_placeholder_0, plid=:db_update_placeholder_1, link_path=:db_update_placeholder_2, router_path=:db_update_placeholder_3, hidden=:db_update_placeholder_4, external=:db_update_placeholder_5, has_children=:db_update_placeholder_6, expanded=:db_update_placeholder_7, weight=:db_update_placeholder_8, depth=:db_update_placeholder_9, p1=:db_update_placeholder_10, p2=:db_update_placeholder_11, p3=:db_update_placeholder_12, p4=:db_update_placeholder_13, p5=:db_update_placeholder_14, p6=:db_update_placeholder_15, p7=:db_update_placeholder_16, p8=:db_update_placeholder_17, p9=:db_update_placeholder_18, module=:db_update_placeholder_19, link_title=:db_update_placeholder_20, options=:db_update_placeholder_21, customized=:db_update_placeholder_22 WHERE (mlid = :db_condition_placeholder_0) ; Array ( [:db_update_placeholder_0] => navigation [:db_update_placeholder_1] => 0 [:db_update_placeholder_2] => catalog [:db_update_placeholder_3] => catalog [:db_update_placeholder_4] => 1 [:db_update_placeholder_5] => 0 [:db_update_placeholder_6] => [:db_update_placeholder_7] => 0 [:db_update_placeholder_8] => 0 [:db_update_placeholder_9] => 1 [:db_update_placeholder_10] => 420 [:db_update_placeholder_11] => 0 [:db_update_placeholder_12] => 0 [:db_update_placeholder_13] => 0 [:db_update_placeholder_14] => 0 [:db_update_placeholder_15] => 0 [:db_update_placeholder_16] => 0 [:db_update_placeholder_17] => 0 [:db_update_placeholder_18] => 0 [:db_update_placeholder_19] => system [:db_update_placeholder_20] => Catalog [:db_update_placeholder_21] => a:0:{} [:db_update_placeholder_22] => 0 [:db_condition_placeholder_0] => 420 ) in menu_link_save() (line 3208 of /var/www/sitename/includes/menu.inc).

  • See drupal.stackexchange.com/a/99353/7641. It's about disabling modules at the database. – Kari Kääriäinen Feb 1 '14 at 21:17
  • This will most probably be closed due to being off topic as a bug in your installation, but what is going on here is the menu_links table in your database should have a has_children small int field in it and for some reason no longer does. So, you will have to do a re-install of your drupal or go in with a database person and recreate that table field. – Jimajamma Feb 2 '14 at 13:54
  • Thanks for the reply, helpful. Yes my DB for this project has a 'has_childrenexpanded' but no has_children. I wonder if I can simply add a new field into the DB without upsetting the Drupal system, it will it merely make it unstable and fallover? I'm confident to hack it myself, or remove any non required bits on advice. – Paul B Feb 2 '14 at 15:26

Browse other questions tagged or ask your own question.