0

I'm setting up a Drupal 7 multisite. Already have another site running with no problem on same server. I can access IMCE browser (see image below), and can upload but not insert images; clicking on image does nothing. When I hard code link to image into a text field, I get 404 'file not found' error.

Setup is standard:

/www/d7 [drupal core]

/www/multisite1 [symlink to ../d7]

/www/multisite2 [symlink to ../d7]

Within /www/d7, also standard setup: sites/multisite1/files, etc. Everything else including Clean URLs is working correctly, and I've set all permissions per usual. I'm stumped, have tried various mod_rewrite directives and none have changed anything. Any possibility there's some path corruption in database? Any other suggestions?

IMCE Display

  • With which wysiwyg editor you are using this? Regarding your screenshot, shouldn't there be upload, insert buttons in the blue top bar? – undersound Feb 5 '14 at 5:42
1

I know your question is 6 months old and you have probably solved it or found a workaround... but I had exactly the same problem and wanted to share what has worked for me, in case it could help others.

At the beginning I had a default single site and IMCE worked perfectly, a few months later I set up another site in multisite configuration, and IMCE didn't work on the second site : no upload, insert, suppress buttons in the top bar, and no possibility to view images or insert them.

In fact it was not a multisite problem, it was due to a jQuery incompatibility.

Both sites use the jQuery Update module :

  • for the default site, the default version is jQuery 1.7
  • for the second one, the default is jQuery 1.9 for the front theme (and 1.7 for the admin theme, but IMCE uses the default version).

If I tried to use 1.7 version for the second site, IMCE get to work.

So, in order to still use jQuery 1.9 or newer (needed by the front theme) and have IMCE working, you can use jQuery Migrate Plugin to resolve incompatibilities.

There is a patch for jQuery Update here, I applied it, get to jQuery Update config page, selected "Enable jQuery Migrate Plugin" (with or without the CDN), and it worked perfectly !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.