0

When using Filtered HTML on a body text, the image uploading button is only appearing for admin users under Tinymce, but not for authenticated users.

How can I fix that?

  • Have authenticated users permission to upload images? – arrubiu Feb 6 '14 at 13:25
  • Hi,there is not such permission under permissions. – sokratis Feb 6 '14 at 16:35
1

I just had the same issue and this is what I found to fix it.

If you have IMCE to control your file browser you must create a profile for each user role. For example, the website administrator (owner of the website) will have access to the file browser no matter what, but if you have another authenticated user with the administrator role, they will not have access to the file browser unless you add a profile to the administrator role. So to do this go to 'admin/config/media/imce' or if you would prefer the interface way, log in as administrator and click on "Configuration" -> "Media" -> "IMCE".

Create a new profile by clicking on "Add New Profile" link and configure the profile to your needs. Save the profile.

Then next to the administrator role (or whatever role you need this for), select that profile you just created and click save.

Now test on a sample administrator (or whatever role you configured) account.

|improve this answer|||||
0

This sounds like a simple Permissions issue. Check your Role Permissions and verify they can Upload Files, and possibly View Uploaded Files.

|improve this answer|||||
  • Did you check the TinyMCE "text input" settings in Drupal? You can toggle what each role sees within the WYSIWYG, you may be missing this simple configuration. – Chris Charlton May 11 '14 at 4:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.