0

I integrated Etherpad on my Drupal site. I did everything as instructed, but still only the administrator role can edit the Etherpad field.

This is how it goes:

Content type X has a text field which is set to be Local Editable in Manage Display (as instructed by the Etherpad readme file).

Furthermore, using the Field Permissions module, the same text field has custom permissions and is editable by authenticated users.

The url for the Etherpad-enabled field goes like this:

http://mysite.com/etherpad/[node:nid]/[etherpad-field-name]#

Despite all this, when I log in as a regular, non-administrator user, I get an "Access denied" message for the field page.

When logged in as admin, when viewing the node, by hovering over the top right corner of field, the "Edit" dropdown appears with the above mentioned url. As a regular user I don't have that option.

0

I just found out that the user needs to have permissions to edit the entire node. Don't know why the field-specific permissions don't work. I had to create a separate content type in order to implement this.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.