0

I am on a Dreamhost dedicated server. I use it to host Drupal sites that our company creates. We recently moved on to this server from another hosting company and have noticed that Batch API features do not work for Drupal 6 or 7. (This same dataset that's failing worked on our last server)

What is the difference? I have upped max_allowed_packet to 100mb, I have increased the Apache timeout to 900 seconds, and have changed the following PHP vars to some pretty high amounts:

max_execution_time = 1600
max_input_time = 1600
memory_limit = 2048M
post_max_size = 2048M

It still won't seem to work. It hangs on initialize and gives me the following message:

An AJAX HTTP error occurred. HTTP Result Code: 403 Debugging information follows. Path: /batch?render=overlay&id=3329&op=do StatusText: Forbidden ResponseText: Access denied

I can run them in the background with Drush, however I have to run core-cron several times over and over to make the import work. This works for some items, but is not ideal as some clients like to use Views Bulk Operations on their sites for managing content.

My server is the top of the line server with 16GB of memory.

1

I solved this by updating "FcgidIOTimeout" in httpd.conf. I set it to an hour.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.