0

I've tried to edit a field in a few content types to set the filtered text format to something other than filtered html, but after I save, it has no effect. I go back to the content type, and it's back to filtered HMTL. If I select "Plain Text" form the "Text processing" setting, I can pick plain text in the "Text format" dropdown, but otherwise, it always saves back to "Filtered HTML". What am I doing wrong?

1

As far as I know, this functionality is "broken" in D7, meaning that the UI is at least misleading. Here's some discussion https://drupal.org/node/1003262

What you can do is change the order of text formats at admin/config/content/formats. The default text format available to users will be according to permissions and the order of text formats.

Also see http://drupal.org/project/better_formats. That will give you more options.

Also see How do you set a default input text format per content type?

  • thanks for your response. I was able to resolve this by only having one option selected, or reordering as you suggested. Thanks. – Jav Feb 25 '14 at 1:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.