1

I've recently installed CKEditor 4 for Drupal 7 module and some of the toolbar's icons don't seem to show up.

They are: Add Media Media Teaser Break and YouTube (to name a few).

I've cleared the Drupal and Browser cache, but that hasn't helped. I've also ensured that I've got the right skins (reuploaded just in case). I tried multiple skins and these same buttons don't seem to want to appear.

Does anyone have any ideas for how to resolve this issue? Test thread is here. http://iloveqatar.net/forum/content/test-0#comment-36224

(Note, I installed CKEditor because I needed an easy solution for users to upload multiple images when created a post so I'm not really attached to CKEditor if someone has a better idea. I was using TinyMCE with the WYSIWYG module)

0
0

Try re-upping the CKeditor library (not the module) and double-check that the owner/file permissions are set correctly on the server.

I believe TinyMCE also works with CKeditor. If you only need to attach images to content and don't need a WYSIWIG editor for your input area, you can add an Image or File field to the content type. If you're using a File field, you might also want to look up the File Entity and Media modules.

1
  • thanks for the advice, I've gone ahead and done that but sadly I've still got blank icons. I do need a basic WYSIWIG, but the goal is to enable a solution where people can upload multiple files at once rather than one at a time (since we have people submitting pics) – amnesia Feb 15 '14 at 16:43
0
  • You should check your browser console if there are any js errors appearing.
  • also check in your wyswig profile page that you have checked the check-boxes for buttons to appear.
  • Even if its not appearing it then you need to write some custom module code to add your buttons on toolbar.

Not the answer you're looking for? Browse other questions tagged or ask your own question.