0

The current snapshot below is of a node which was edited before I installed i18n. So when I go to edit that node "Translate" tab does not appear.

I've many nodes like this. The problem in such nodes is that in the language switcher block, all languages are shown enabled even though translations aren't available.

What is the solution? Should I simply resave such nodes created before i18n was installed?

So in this current snapshot, all non-English languages should have been shown as striked as I've not enabled translation for this node.

enter image description here

0

Manually saving those pre-existing nodes does it. Untranslated languages are shown striked out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.