I have some taxonomy terms and the settings look like this.

enter image description here

All these terms have been translated.

enter image description here

After indexing the content with Search API and Facets API, the facets are not shown with translation.

enter image description here

Why is it happening?

To localize FacetAPI you should install FacetAPI i18n.

The Facet API Translation module integrates the Facet API and Internationalization projects allowing site builders to translate configuration settings. This module also overrides common mapping callbacks, such as the content type mapping callback, to translate the display name of facets.

  • thanks for the suggestion. But i found out from these links thats you need to translate each taxonomy from translate interface. which is not a solution yet . drupal.org/node/1210730#comment-4701718 drupal.org/node/1276812#comment-6727336 drupal.org/node/1340858 – brainHax Feb 18 '14 at 13:29
  • Just found out that if your taxonomy field is indexed as a "Term Taxonomy", it will expose a facet block which will show translated terms (no need for translate interface). in my case the block name was "Facet API: Search service: recepie index : cat" – brainHax Feb 19 '14 at 10:13
  • btw "Facet API Translation" module is disabled . – brainHax Feb 19 '14 at 10:15

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.