2

My Drupal site gives a 404 error in firebug, even though the login form is showing. Also nothing happens when you click Log in-- the page just refreshes and login DOES NOT happen. This only happens in https. There is no error in HTTP and the login is working.

I have installed the secure_login module hoping it might help, but no change. Basically, it just forced the login page to redirect to https.

I thought maybe the https is not configured correctly, but HTTPS is working fine in all the other pages. My site works in both http and https. The only problem is the login form.

NewtworkError: 404 Not Found

3
  • What is this js_L2_...57ls.js on the pic?
    – Wtower
    Feb 18, 2014 at 9:38
  • This is just javaScript; 'referrer' is a console log message. Feb 18, 2014 at 15:18
  • Of course it is.... too hasty sometimes.
    – Wtower
    Feb 18, 2014 at 15:36

2 Answers 2

5

The solution is in your Apache config file. Enable ‘LoadModule rewrite_module modules/mod_rewrite.so’ in httpd.conf file and clear the cache and then login again.

1
  • 1
    This should be the accepted answer!!!
    – Sorin
    Oct 18, 2015 at 21:52
0

Bikashphp's answer above (Enable ‘LoadModule rewrite_module modules/mod_rewrite.so’ in httpd.conf file) worked for me, but I had to add an extra step of installing mod_rewrite. Here are instructions on how to do that:

In order to use mod_rewrite you can type the following command in the terminal:

a2enmod rewrite

Restart apache2 after

/etc/init.d/apache2 restart

or

service apache2 restart

From: https://stackoverflow.com/questions/869092/how-to-enable-mod-rewrite-for-apache-2-2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.