3

My site's drupal version is 6.19. There are always logs like the following.

the recent log entries shows

type: page not found
location:http://www.example.com/display.html
referrer:
  message: 500.shtml
  severity: warning
  hostname: 95.64.11.29 or others (maybe search engine robot IP)

The URL and the content is right, but when the anonymous user accesses it, it returns the "Page not found" page. Anonymous users have the permissions to access content.

The cache_page table contains the following header for http://www.example.com/display.html:

Content-Type: text/html; charset=utf-8 HTTP/1.1 404 Not Found

Why is the page being cached as "404 Not Found", when it actually exists?

When I access http://www.example.com/display.html as an anonymous user, the site shows "page not found"; when I clear the cache, anonymous users can access the page.
How can I correct the cached content generated by search engine bots?

  • Would it be possible for you to link to exact url? Is the url live somewhere? – Dipen Mar 19 '11 at 10:14
  • What I meant was, can u post it here? – Dipen Mar 19 '11 at 10:33
  • i am from china,maybe you don't know the characters on the page. – enjoylife Mar 19 '11 at 11:09
  • the page is exactly exist. if i cleared the cache or the one cron finished, the anonymous can access the page. – enjoylife Mar 19 '11 at 11:18
  • What does your logs say? Also have u tried cache exclude module? Try and exclude that page from caching and see if it works fine? Want to know if its just this page or others page could be affected. – Dipen Mar 19 '11 at 12:08
2

Is the page actually handled by Drupal or is it a static .html file? It looks like a file that shouldn't be handled by Drupal, the 500 error http://www.checkupdown.com/status/E500.html indicates a fatal server error.

If it is handled by Drupal can you change the url to one without the .html & see if that works with caching. You could use the global_redirect module to forward the .html addresses, once you figure out why it's failing.

If it is a flat file you may need to change the .htaccess or settings.php file to allow the .html to be processed by the webserver without bootstrapping Drupal.

There is a massive thread about this issue on Drupal.org http://drupal.org/node/76824#comment-3299738 You may find an answer in there.

PS If this is served on a shared host you may want to contact your provider, they can have some strange setups & can fix quickly if you explain clearly what is happening.

  • it's the story article. – enjoylife Mar 23 '11 at 10:51
  • Try changing the 'URL path settings' by editing that article, make it so that it doesn't end with .html. – Drew Mar 23 '11 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.