0

As in the image(of German node), I'm outputting a text link in English: "Report an Issue" using Computed Field module so it looks like: $text = t("Report an Issue"); in the php code.

I've then translated it by going to admin/config/regional/translate/translate in all supported languages.

The problem is that sometimes I see the English version: "Report an Issue" in the non-English nodes. Many times it looks fine. But when I clear all caches, it shows fine. While all the node title, fields, labels show correct translation only except this field. The url is see is mysite.com/de/title which is as expected.

I'm only using i18n and not Entity Translation.

What could be the problem?

After all cache clear this field always show correctly

  • After clear all cache it work correctly but later get return to english version in non-english node? – Yusef Feb 19 '14 at 6:24
  • @zhilevan Yes it shows correctly for the current node but for any other non-English node it may not. – AgA Feb 19 '14 at 6:47
  • What do you have in admin/config/regional/language/configure? – Kari Kääriäinen Feb 19 '14 at 6:49
  • First is URL, then User then Session. – AgA Feb 19 '14 at 6:53
  • @Gisle Hannemyr it was in English then I installed i18n and enabled 8 languages(German,French,Russian,Chinese,Japanese etc) – AgA Feb 19 '14 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.