1

Cron seems to complete, but I get a message stating that a file could not be created.

Do you have any idea about what is causing this?

3 Answers 3

1

You need to give the 777 directory permission to your temp folder. Like.... sudo chmod 777 -R /var/www/html/yoursite/sites/default/files/temp/

Please check images for more understanding. enter image description here

enter image description here

and command for give 777 permission to that directory like...

enter image description here

0

Sounds like a file permissions issue. Check this: https://drupal.org/node/244924

2
  • Yes, I agree but I made no permission changes. My hosting company (GreenGeeks) is not helping.I'm trying to locate the directory now.
    – John
    Feb 21, 2014 at 19:37
  • Some hosting companies does some maintenance on the servers that sometimes affects the file permissions. Check how is currently the file permissions at the admin panel of the web hosting service. Also, at admin/settings/file-system check for errors messages on the "file system paths" and "temp directory". If you have enabled the dblog or the syslog module, check the logs to get more info about this issue.
    – gerzenstl
    Feb 21, 2014 at 22:15
0

You can just change the temporary directory link found at sitename/admin/config/media/file-system to /tmp and save.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.