1

Just recently I finished my friend's site on my local wamp server. Looks great on that server. Now I tried to migrate the site to a Godaddy shared hosting account. I was able to get it all setup with the database up to date and everything, but the second I log in the the backend of Drupal, it white screens. Again tried a different browser, the site came up fine until I logged into the admin again. At this point I can't get any page to load, not even the home page. I can delete my cookies in the browser to log myself out but that's about it. So stumped its not even funny...

2

Check the official Drupal page for "white screen of death" (WSOD), you will useful guidance to help you to find the problem.

As my suggestion, enable temporaly the error report for php, adding on the index.php the following lines:

error_reporting(E_ALL);
ini_set('display_errors', TRUE);
ini_set('display_startup_errors', TRUE);

Another thing that you could do is to go to admin page of your Godaddy shared hosting account and enable the option error.

A last thing, check if you have copied the .htaccess file too on the directory of the web hosting server.

  • Reviewed the WSOD page heavily. Enabled error reporting and got nothing. My friend's server doesn't have error log capabilities so I can't see Apache errors that way. And when I did a fresh install I did copy the htaccess file. – brettzenor Feb 27 '14 at 19:29
1

This might probably be relevant to an issue with GoDaddy that requires you to uncomment the line:

  # If your site is running in a VirtualDocumentRoot at http://example.com/,
  # uncomment the following line:
   RewriteBase /

in the .htaccess file at the root of your installation.

  • 1
    Would it be a problem that I am running this site in directory other than the root directory, like dev/. I suppose I should be using RewriteBase /dev/? – brettzenor Feb 27 '14 at 19:34
  • Yes, you should. – Wtower Feb 28 '14 at 6:36
  • I updated the .htaccess file as you directed with RewriteBase /dev/ and the problem unfortunately continues – brettzenor Feb 28 '14 at 7:18
1

I solved it!

The PHP version on the live Godaddy server was incompatible with my specific build of Drupal. The PHP version was set to 5.2 and I was able to change it to 5.3. This fixed my WSOD problems when I logged in as admin to the live server.

Thank you everyone for the much appreciated help and support!

0

Look in the PHP logs: http://support.godaddy.com/help/article/1197/working-with-error-logs and see what the error is. I would post it back here and someone may be able to give you a specific resolution.

You can try running update.php, which may fix the issue. You can update the setting update_free_access=TRUE in your settings.php file: https://drupal.org/upgrade/running-update-php

That being said, the correct way to move to a production site is to back up your /sites folder, and do a fresh install of drupal on the production server. Replace everything but the /sites/default/settings.php file with your backed up /sites folder.

More here on migrating a development instance of Drupal to a live development server: https://drupal.org/node/501724

  • I don't have error logs unfortunately due to my friend's economy shared host. I tried update.php and got that page to display but nothing needed to be done. I did a fresh install and copied the sites/ directory minus the settings.php file, like you said, then imported the sql file in phpmyadmin on top of the existing fresh site. Same thing, I can see the home page but the second I log in, all pages are gone. – brettzenor Feb 27 '14 at 19:32
  • Found some errors in my watchdog table in my database link Apparently I'm getting access denied errors. Could this be a problem with permissions? – brettzenor Feb 28 '14 at 1:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.